Closed Bug 1202215 Opened 4 years ago Closed Last year

Ugly line on top of selected tab on Windows 10

Categories

(Firefox :: Theme, defect)

40 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: admrlspeedy, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(5 files)

Attached image Tab Line.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Open Firefox.
Look that top edge of the currently selected tab button.


Actual results:

A small line is drawn on the top edge of the tab.


Expected results:

No line should be drawn.
OS: Unspecified → Windows 10
I noticed this issue after upgrading and then clean installing Windows 10. If you don't have colored title bars enable in Windows 10, you don't notice this line because it blends in with the title bar.

I have searched up images and found several that also have colored title bars enable on Windows 10, resulting in the dark grey title bar but no line on the top edge of the tab (http://i1-news.softpedia-static.com/images/news2/mozilla-firefox-40-released-with-windows-10-improvements-488972-2.jpg).

I reinstalled Firefox and the issue remains and I have confirmed that it's not just my system by testing several different Windows 10 systems, all of which have the same issue.

I have solved it with a userChrome file with the following:

	.tabbrowser-tab[selected] { 
		margin-top: -1px !important;
	}

It should still be fixed in the default theme.
Component: Untriaged → Theme
Blocks: windows-10
Summary: Ugly line on top of selected tab → Ugly line on top of selected tab on Windows 10
I don't know what you mean by "colored titlebars in Windows 10", because the Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight theme and this is a duplicate of bug 1186244 (for a clearer summary see bug 1188282, which was duped there).

Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/) and/or provide more details about how to reproduce this from a clean Firefox profile ( https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles ) ?
Flags: needinfo?(admrlspeedy)
I remember jaws was seeing this on 125% DPI on default theme. Maybe that's the bug he's hitting ?
(In reply to Tim Nguyen [:ntim] from comment #3)
> I remember jaws was seeing this on 125% DPI on default theme. Maybe that's
> the bug he's hitting ?

Nope. I'm using 100% scaling.
Flags: needinfo?(admrlspeedy)
(In reply to :Gijs Kruitbosch from comment #2)
> I don't know what you mean by "colored titlebars in Windows 10", because the
> Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight
> theme and this is a duplicate of bug 1186244 (for a clearer summary see bug
> 1188282, which was duped there).
> 
> Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/)
> and/or provide more details about how to reproduce this from a clean Firefox
> profile (
> https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> profiles ) ?

Those two bugs you posted seem to be exactly the issue. I couldn't find anything when I searched.

The colored title bar thing I'm talking about is re-enabling Aero colored title bars in Windows 10. By default in Windows 10 all title bars are just white. You can either go into the them folder and load the Aero theme or use a tool called Winaero Tweaker to enable color title bars. Either way when you enable them, the title bar in Firefox turns grey which makes this bug visible.
(In reply to :Gijs Kruitbosch from comment #2)
> I don't know what you mean by "colored titlebars in Windows 10", because the
> Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight
> theme and this is a duplicate of bug 1186244 (for a clearer summary see bug
> 1188282, which was duped there).
> 
> Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/)
> and/or provide more details about how to reproduce this from a clean Firefox
> profile (
> https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> profiles ) ?

41 does not fix this issue. I will continue using my userChrome file until it's fixed.
(In reply to :Gijs Kruitbosch from comment #2)
> I don't know what you mean by "colored titlebars in Windows 10", because the
> Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight
> theme and this is a duplicate of bug 1186244 (for a clearer summary see bug
> 1188282, which was duped there).
> 
> Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/)
> and/or provide more details about how to reproduce this from a clean Firefox
> profile (
> https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> profiles ) ?

To reproduce on a clean profile, download "http://winaero.com/comment.php?comment.news.1836" this and enable "Colored Title Bars" with it on Windows 10.

Start Firefox and you will immediately see the issue.
(In reply to Mitchell from comment #5)
> (In reply to :Gijs Kruitbosch from comment #2)
> > I don't know what you mean by "colored titlebars in Windows 10", because the
> > Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight
> > theme and this is a duplicate of bug 1186244 (for a clearer summary see bug
> > 1188282, which was duped there).
> > 
> > Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/)
> > and/or provide more details about how to reproduce this from a clean Firefox
> > profile (
> > https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> > profiles ) ?
> 
> Those two bugs you posted seem to be exactly the issue. I couldn't find
> anything when I searched.
> 
> The colored title bar thing I'm talking about is re-enabling Aero colored
> title bars in Windows 10. By default in Windows 10 all title bars are just
> white. You can either go into the them folder and load the Aero theme or use
> a tool called Winaero Tweaker to enable color title bars. Either way when
> you enable them, the title bar in Firefox turns grey which makes this bug
> visible.

I'm confused. The Firefox titlebar has been grey (rather than white) without any external software installed since Firefox 40. That was implemented in bug 1173725. Does turning off this external utility thing fix the issue without changing the titlebar's color?
Flags: needinfo?(admrlspeedy)
Flags: needinfo?(admrlspeedy)
Attached file Custom userChrome File
(In reply to :Gijs Kruitbosch from comment #8)
> (In reply to Mitchell from comment #5)
> > (In reply to :Gijs Kruitbosch from comment #2)
> > > I don't know what you mean by "colored titlebars in Windows 10", because the
> > > Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight
> > > theme and this is a duplicate of bug 1186244 (for a clearer summary see bug
> > > 1188282, which was duped there).
> > > 
> > > Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/)
> > > and/or provide more details about how to reproduce this from a clean Firefox
> > > profile (
> > > https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> > > profiles ) ?
> > 
> > Those two bugs you posted seem to be exactly the issue. I couldn't find
> > anything when I searched.
> > 
> > The colored title bar thing I'm talking about is re-enabling Aero colored
> > title bars in Windows 10. By default in Windows 10 all title bars are just
> > white. You can either go into the them folder and load the Aero theme or use
> > a tool called Winaero Tweaker to enable color title bars. Either way when
> > you enable them, the title bar in Firefox turns grey which makes this bug
> > visible.
> 
> I'm confused. The Firefox titlebar has been grey (rather than white) without
> any external software installed since Firefox 40. That was implemented in
> bug 1173725. Does turning off this external utility thing fix the issue
> without changing the titlebar's color?

I got a bit mixed up in my wording, but I've uploaded three image attachments that should clear up the issue, which is still occurring on 41.0b7. This issue is unrelated to the tool I suggested. The tool simply provides an easy method of using the Aero theme with colored title bars within Windows 10. You can go to the default Windows 10 theme folder and enable it manually. I've attached the "Windows 10 Colored Title Bars ON/OFF Example" image to show exactly what I mean.

Now, what I said about the colors before was actually backwards. If you DON'T have colored title bars enabled in Windows 10 the title bar in Firefox is a dark grey color (see the "Windows 10 Colored Title Bars ON/OFF Firefox Example" attachment) and there is clearly a line/border on the top edge of whichever tab is currently selected and it's very ugly. When you DO have colored title bars enabled, Firefox changes to a very light grey color which hides this border/line because it's almost the same color as the line itself, again this can be seen in the "Windows 10 Colored Title Bars ON/OFF Firefox Example" attachment.

Now, to fix this issue (and the issue of the Minimize, Maximize and Close buttons being white with colored title bars enabled), I wrote a custom userChrome file that I have also attached. This file fixes those issues and enables the Firefox title bar to change to whatever color you have the Windows title bars set to, again resulting in the visibility of the line on top of the selected tab (see the "Firefox with userChrome File"). The attached userChrome file contains my fix for this issue at the very bottom of it. It's commented it currently so to test it just un-comment it.
(In reply to Mitchell from comment #13)
> (In reply to :Gijs Kruitbosch from comment #8)
> > (In reply to Mitchell from comment #5)
> > > (In reply to :Gijs Kruitbosch from comment #2)
> > > > I don't know what you mean by "colored titlebars in Windows 10", because the
> > > > Windows pref doesn't affect Firefox. I *suspect* you're using a lightweight
> > > > theme and this is a duplicate of bug 1186244 (for a clearer summary see bug
> > > > 1188282, which was duped there).
> > > > 
> > > > Can you confirm if this is fixed in Firefox 41 (https://beta.mozilla.org/)
> > > > and/or provide more details about how to reproduce this from a clean Firefox
> > > > profile (
> > > > https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> > > > profiles ) ?
> > > 
> > > Those two bugs you posted seem to be exactly the issue. I couldn't find
> > > anything when I searched.
> > > 
> > > The colored title bar thing I'm talking about is re-enabling Aero colored
> > > title bars in Windows 10. By default in Windows 10 all title bars are just
> > > white. You can either go into the them folder and load the Aero theme or use
> > > a tool called Winaero Tweaker to enable color title bars. Either way when
> > > you enable them, the title bar in Firefox turns grey which makes this bug
> > > visible.
> > 
> > I'm confused. The Firefox titlebar has been grey (rather than white) without
> > any external software installed since Firefox 40. That was implemented in
> > bug 1173725. Does turning off this external utility thing fix the issue
> > without changing the titlebar's color?
> 
> I got a bit mixed up in my wording, but I've uploaded three image
> attachments that should clear up the issue, which is still occurring on
> 41.0b7. This issue is unrelated to the tool I suggested. The tool simply
> provides an easy method of using the Aero theme with colored title bars
> within Windows 10. You can go to the default Windows 10 theme folder and
> enable it manually. I've attached the "Windows 10 Colored Title Bars ON/OFF
> Example" image to show exactly what I mean.
> 
> Now, what I said about the colors before was actually backwards. If you
> DON'T have colored title bars enabled in Windows 10 the title bar in Firefox
> is a dark grey color (see the "Windows 10 Colored Title Bars ON/OFF Firefox
> Example" attachment) and there is clearly a line/border on the top edge of
> whichever tab is currently selected and it's very ugly. When you DO have
> colored title bars enabled, Firefox changes to a very light grey color which
> hides this border/line because it's almost the same color as the line
> itself, again this can be seen in the "Windows 10 Colored Title Bars ON/OFF
> Firefox Example" attachment.
> 
> Now, to fix this issue (and the issue of the Minimize, Maximize and Close
> buttons being white with colored title bars enabled), I wrote a custom
> userChrome file that I have also attached. This file fixes those issues and
> enables the Firefox title bar to change to whatever color you have the
> Windows title bars set to, again resulting in the visibility of the line on
> top of the selected tab (see the "Firefox with userChrome File"). The
> attached userChrome file contains my fix for this issue at the very bottom
> of it. It's commented it currently so to test it just un-comment it.

four image attachments*
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.