[Contacts]When user edits a contact, the color of the status bar in contact detail view will change to white.

RESOLVED DUPLICATE of bug 1201052

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1201052
2 years ago
2 years ago

People

(Reporter: SandKing, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-2])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8657549 [details]
Bug log: logcat_1430.txt

[1.Description]:
[AriesKK v2.5][FlameKK v2.5][Contacts]When user edits a contact and the device backs to contact detail view, and the color of the status bar in contact detail view will change to white. 
See log:"logcat_1430.txt"
See video:"Aries_v2.5.3GP"
Found Time:14:30

[2.Testing Steps]: 
Precondition: There are some contacts in device.
1. Launch "Contacts".
2. Select one of the contact in contacts list.
**The Status bar in contact detail view is Blue
3. Tap the "Edit" icon from contact detail view.
4. Change something of the contact and tap the "Update" icon.


[3.Expected Result]: 
4. The Status bar should keep the same color as that in Step 2.

[4.Actual Result]: 
4. The status bar will change to white color in contact detial view.

[5.Reproduction build]: 
Device: Aries KK v2.5 (Affected)
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 (Affected)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.183746
Firmware Date          Sat Sep  5 18:38:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.2 (Unaffected)
Build ID               20150905032501
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d3cb4f28c735
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test
(Reporter)

Comment 1

2 years ago
Created attachment 8657550 [details]
Bug video: Aries_v2.5.3GP
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Reporter)

Updated

2 years ago
Keywords: regression
QA Contact: qiutian
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819054940
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gaia Date              2015-08-19 12:01:44
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819061537
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gaia Date              2015-08-19 12:27:22
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro 
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

First Broken Gecko & Last Working Gaia - issue DOES NOT repro 
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c

Possibly caused by Bug 1183727.
Hi Borja,
This bug is probably caused by Bug 1183727, could you help to check?  
Thank you.
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(borja.bugzilla)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201052
Flags: needinfo?(borja.bugzilla)
You need to log in before you can comment on or make changes to this bug.