segmentation fault on mozilla-release/ipc/glue/MessageChannel.cpp#L1597

UNCONFIRMED
Unassigned

Status

()

Core
IPC
P3
normal
UNCONFIRMED
3 years ago
10 months ago

People

(Reporter: Seong-ho Cho, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(e10s-)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150731021746

Steps to reproduce:

i have an issue on Firefox 39.0, gcc 4.9.3/amd64 in the gentoo distribution.
i've seen the same issue that marked as "RESOLVED FIXED", but it doesn't yet very really fixed.

i have met this warning and die message during scrolling a facebook timeline containing a movie, and windows has unexpectedly closed.


Actual results:

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15357:21
Vector smash protection is enabled.
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15357:21
error: XDG_RUNTIME_DIR not set in the environment.
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15357:21
error: XDG_RUNTIME_DIR not set in the environment.
error: XDG_RUNTIME_DIR not set in the environment.
error: XDG_RUNTIME_DIR not set in the environment.
error: XDG_RUNTIME_DIR not set in the environment.
[NPAPI 25125] ###!!! ABORT: Aborting on channel error.: file /var/tmp/portage/www-client/firefox-39.0/work/mozilla-release/ipc/glue/MessageChannel.cpp, line 1597
[NPAPI 25125] ###!!! ABORT: Aborting on channel error.: file /var/tmp/portage/www-client/firefox-39.0/work/mozilla-release/ipc/glue/MessageChannel.cpp, line 1597
Segmentation fault



Expected results:

There should be no happen, anything..
(Reporter)

Comment 1

3 years ago
additional info ...

1583 void
1584 MessageChannel::OnChannelErrorFromLink()
1585 {
1586     AssertLinkThread();
1587     mMonitor->AssertCurrentThreadOwns();
1588 
1589     if (InterruptStackDepth() > 0)
1590         NotifyWorkerThread();
1591 
1592     if (AwaitingSyncReply() || AwaitingIncomingMessage())
1593         NotifyWorkerThread();
1594 
1595     if (ChannelClosing != mChannelState) {
1596         if (mAbortOnError) {
1597             NS_RUNTIMEABORT("Aborting on channel error.");
1598         }
1599         mChannelState = ChannelError;
1600         mMonitor->Notify();
1601     }
1602 
1603     PostErrorNotifyTask();
1604 }

https://bugzilla.mozilla.org/show_bug.cgi?id=1047160

This seem to be a same issue.

Comment 2

3 years ago
Are you using the official build for Linux?
Flags: needinfo?(darkcircle.0426)
Seong-ho, do you have steps to reproduce this error?

This abort may be a response to the e10s child process crashing.
Blocks: 879538
tracking-e10s: --- → ?
Component: Untriaged → IPC
Product: Firefox → Core
(Reporter)

Comment 4

3 years ago
@Loi(In reply to Loic from comment #2)
> Are you using the official build for Linux?

I've build on myself.
Flags: needinfo?(darkcircle.0426)
(Reporter)

Comment 5

3 years ago
(In reply to Chris Peterson [:cpeterson] from comment #3)
> Seong-ho, do you have steps to reproduce this error?
> 
> This abort may be a response to the e10s child process crashing.

It crashes when I'm trying to see php documentation(very repeatedly).
Flags: needinfo?(wmccloskey)
Another question, do you have some crash IDs you could paste here (from about:crashes)? Thanks!
Flags: needinfo?(darkcircle.0426)
Since this is presumably a custom build (Gentoo), crash IDs won't be helpful. It's FF 39, so it's not e10s-related. Seong-ho, is there any chance you could install a Mozilla-built version of Firefox and see if it still reproduces? If so, crash IDs would then be helpful.

This error signals that something is going wrong in a different process, so we need crash information from that process. Hopefully the crash ID would provide it.
tracking-e10s: ? → -
Flags: needinfo?(wmccloskey)
(Reporter)

Comment 8

3 years ago
I was upgrade to 40.0.3 about 3 days ago, and I found these log during the days with logs I've already attached initially.

It's just like GStreamer related issue, but not only related on the GStreamer.

-----------------------------------------

(firefox:24059): GStreamer-CRITICAL **: gst_mini_object_lock: assertion 'object != NULL' failed

(firefox:24059): GStreamer-CRITICAL **: gst_memory_unmap: assertion 'mem != NULL' failed

(firefox:24059): GStreamer-CRITICAL **: gst_memory_get_sizes: assertion 'mem != NULL' failed
Segmentation fault

-----------------------------------------

plus, I can't access to the about:crashes page, so I cannot paste crash ID on here.(Oops)
Flags: needinfo?(darkcircle.0426)
(Reporter)

Comment 9

3 years ago
(In reply to Loic from comment #2)
> Are you using the official build for Linux?

so, I tried to test by using binary package again... similar problem is also appeared, but It's rare than self-built firefox.

Updated

10 months ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.