Building Firefox with --disable-webrtc fails

RESOLVED DUPLICATE of bug 1204382

Status

()

P1
normal
Rank:
15
RESOLVED DUPLICATE of bug 1204382
3 years ago
3 years ago

People

(Reporter: johnp, Assigned: jesup)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
Build failure:

In file included from /gecko-dev/obj-x86_64-unknown-linux-gnu/dom/media/systemservices/Unified_cpp_systemservices0.cpp:11:0:
 /gecko-dev/dom/media/systemservices/MediaParent.cpp: In member function ‘nsresult mozilla::media::OriginKeyStore::OriginKeysLoader::Read()’:
 /gecko-dev/dom/media/systemservices/MediaParent.cpp:169:64: error: no matching function for call to ‘do_QueryInterface(nsCOMPtr<nsIInputStream>&)’
        nsCOMPtr<nsILineInputStream> i = do_QueryInterface(stream);

buildlog: https://pastebin.mozilla.org/8845362

mozconfig: https://pastebin.mozilla.org/8845361

Commenting out the --disable-webrtc line makes the build run successfully.
(Reporter)

Updated

3 years ago
Summary: Building with --disable-webrtc fails → Building Firefox with --disable-webrtc fails
Assignee: nobody → rjesup
backlog: --- → webrtc/webaudio+
Rank: 15
Priority: -- → P1
(Reporter)

Comment 1

3 years ago
Fixed in bug 1202239.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
meant bug 1204382 ofc ^^
(Reporter)

Updated

3 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1204382
You need to log in before you can comment on or make changes to this bug.