Closed Bug 1202274 Opened 6 years ago Closed 5 years ago

Code area in event listeners tooltip has unnecessary 5px indent at the bottom

Categories

(DevTools :: Inspector, defect)

defect
Not set
normal

Tracking

(firefox43 affected)

RESOLVED DUPLICATE of bug 1202260
Tracking Status
firefox43 --- affected

People

(Reporter: arni2033, Unassigned)

References

()

Details

Attachments

(1 file, 1 obsolete file)

STR:   (Win7_64, Nightly 43, 32bit, ID 20150901030226, new profile, safe mode)
1. Open this "data:" url or click URL in the field above
data:text/html,<body onload="var str=''; for (i=1;i<999;i++)str+='L'; for (i of ['oncut','onpaste','oncopy'] ) document.body.setAttribute(i,str); ">
2. Open devtools->Inspector, click (ev) button near <body> element
3. Click 2nd event listener button to show the code area

Result:       Code area has unnecessary 5px indent at the bottom (actually, 4px)
Expectations: There should be no indent

Suggestion:   It looks fixed if I apply any ONE of CSS styles below (using extension "Stylish"), so this is suggested solution. I hope somebody will find time to make a patch
>   .event-tooltip-content-box[open]
>   {
>     font-size:0px;
>   }

>   .event-tooltip-content-box[open]
>   {
>     line-height: 9px; /* or less than 9px. Idk how this one works */
>   }

>   .event-tooltip-content-box[open]
>   {
>     height:100px;
>     overflow:hidden;
>   }
The last one may look good, but it interferes with style in bug 1202260 - I asked there for adding 1px border for code area, so if that suggestion will be accepted, then "height" in the last option here should be set to 101px instead of 100px.
Attachment #8659412 - Attachment is obsolete: true
Attachment #8659412 - Flags: review?(mhaigh)
Has STR: --- → yes
Depends on: 1202260
I can confirm that this is now fixed thanks to bug 1202260.
I did the fix in bug 1202260 because it was a simple CSS change that I could do at the same time.
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1202260
Resolution: --- → DUPLICATE
Duplicate of bug: 1202260
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.