Closed Bug 1202402 Opened 5 years ago Closed 5 years ago

Nothing shown on the standalone UI when a peer exits the room

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox43 verified)

VERIFIED FIXED
mozilla43
Iteration:
43.3 - Sep 21
Tracking Status
firefox43 --- verified

People

(Reporter: standard8, Assigned: Mardak)

References

Details

(Keywords: regression)

Attachments

(1 file)

Following bug 1126733, I've just noticed that when a peer exits the room, the standalone now doesn't display anything, not even after a timeout.

Displaying "You're the first one here" is probably wrong, Sevaan, what should we do?

(P1 as its a regression we should fix before next release)
Flags: qe-verify+
Flags: needinfo?(sfranks)
Flags: firefox-backlog+
Rank: 16
This is caused by didUpdate checking only for JOINING but when the other participant leaves, the state goes to SESSION_CONNECTED:

http://mxr.mozilla.org/mozilla-central/source/browser/components/loop/standalone/content/js/standaloneRoomViews.jsx#124

We could just add a check to allow for SESSION_CONNECTED as well and there won't be duplicate timers because we explicitly check for _waitTimer === undefined.

standard8's comment of 'showing "first one here" might be wrong' seems valid. Perhaps "only one here" ? Should it say "first" on the first time and "only" on the subsequent times? Or always "only one here"?
Assignee: nobody → edilee
Attached patch v1Splinter Review
Interestingly, the string label was already "rooms_only_occupant_label" but had a localized text of "first"
Attachment #8657946 - Flags: review?(standard8)
I thought we had settled on "only" instead of "first" in a bug a while back.

Let's go with "You're the only one here."

NI'ing Matej to confirm.
Flags: needinfo?(sfranks) → needinfo?(matej)
(In reply to Sevaan Franks [:sevaan] from comment #3)
> I thought we had settled on "only" instead of "first" in a bug a while back.
> 
> Let's go with "You're the only one here."
> 
> NI'ing Matej to confirm.

+1
Flags: needinfo?(matej)
Iteration: --- → 43.3 - Sep 21
Comment on attachment 8657946 [details] [diff] [review]
v1

Review of attachment 8657946 [details] [diff] [review]:
-----------------------------------------------------------------

I think this is fine, in some ways it'd be nice not to have the delay when they exit, but its not a massive one, so lets see how it feels.

r=Standard8

::: browser/locales/en-US/chrome/browser/loop/loop.properties
@@ +323,5 @@
>  rooms_list_delete_tooltip=Delete conversation
>  rooms_list_deleteConfirmation_label=Are you sure?
>  rooms_change_failed_label=Conversation cannot be updated
>  rooms_new_room_button_label=Start a conversation
> +rooms_only_occupant_label2=You're the only one here.

Please can you drop the string from this file - its standalone specific, so localisers don't need to translate on desktop.
Attachment #8657946 - Flags: review?(standard8) → review+
https://hg.mozilla.org/integration/fx-team/rev/008aa66eb51f9ac8a9ee2ee33bd669b89c1a702c
Bug 1202402 - Nothing shown on the standalone UI when a peer exits the room [r=Standard8]
https://hg.mozilla.org/mozilla-central/rev/008aa66eb51f
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
QA Contact: bogdan.maris
I was unable to reproduce the initial behavior (since this was a standalone issue).
I verified that using stage server ('loop.server; https://loop-dev.stage.mozaws.net/v0') after the peer exits the conversation, standalone will display 'You're the only one here.' message after a small delay.
Testing was done using latest Developer Edition 43.0a2 across platforms (Windows 7 64-bit, Windows 10 64-bit, Mac OS X 10.10.5 and Ubuntu 14.04 32-bit).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.