Closed Bug 1202427 Opened 4 years ago Closed 3 years ago

Implement drawRangeElements

Categories

(Core :: Canvas: WebGL, defect, P1)

x86
Windows 8.1
defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- fixed
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: jujjyl, Assigned: jgilbert)

References

Details

(Keywords: dev-doc-complete, Whiteboard: [gfx-noted])

Attachments

(4 files)

James Moran from Epic reported the following testcase, which showcases that our WebGL2 function drawRangeElements() is not producing output. See the attached example.

STR:
1. Enable WebGL 2 by setting the browser prefs

webgl.bypass-shader-validation: true
webgl.disable-angle: true
webgl.enable-draft-extensions: true
webgl.enable-prototype-webgl2: true
webgl.force-enabled: true

2. Unzip the attachment, run embedded-drawRangeElements.html

Observed: One spinning cube is rendered.

Expected: Two spinning cubes should be rendered next to each other.
The issue can be worked around with the following JS code after GL context initialization:

    gl.drawRangeElements = function(mode, start, end, count, type, indices) {
      gl.drawElements(mode, count, type, indices);
    }

although that kind of defeats the purpose of the drawRangeElements function altogether.
Whiteboard: [gfx-noted]
Assignee: nobody → kyle_fung
Summary: WebGL2 drawRangeElements does not function. → Implements drawRangeElements
Assignee: kyle_fung → jgilbert
Priority: -- → P1
Summary: Implements drawRangeElements → Implement drawRangeElements
Duplicate of this bug: 898475
Comment on attachment 8820131 [details]
Bug 1202427 - Stub DrawRangeElements into DrawElements. -

https://reviewboard.mozilla.org/r/99670/#review100090

It looks like a workaround version. r+ for we should open a follow-up bug to make it done.
Attachment #8820131 - Flags: review?(dmu) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/64eeb4a05bfe
Stub DrawRangeElements into DrawElements. - r=daoshengmu
https://hg.mozilla.org/mozilla-central/rev/64eeb4a05bfe
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8820131 [details]
Bug 1202427 - Stub DrawRangeElements into DrawElements. -

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]:
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8820131 - Flags: approval-mozilla-beta?
Attachment #8820131 - Flags: approval-mozilla-aurora?
Comment on attachment 8820131 [details]
Bug 1202427 - Stub DrawRangeElements into DrawElements. -

Fix WebGL2 related issue. Beta51+ & Aurora52+. Should be in 51 beta 10.
Attachment #8820131 - Flags: approval-mozilla-beta?
Attachment #8820131 - Flags: approval-mozilla-beta+
Attachment #8820131 - Flags: approval-mozilla-aurora?
Attachment #8820131 - Flags: approval-mozilla-aurora+
Check-in: https://hg.mozilla.org/releases/mozilla-aurora/rev/4cd2b1eaa3d3 - Jeff Gilbert - Bug 1202427 - Stub DrawRangeElements into DrawElements. - r=daoshengmu. a=gchang
You need to log in before you can comment on or make changes to this bug.