Status

SeaMonkey
Themes
--
critical
VERIFIED DUPLICATE of bug 115919
17 years ago
10 years ago

People

(Reporter: Chu Alan #2, Assigned: Joe Hewitt (gone))

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020115
BuildID:    2002011508

Tried serveral times ... it still crash when i change themes back and forth ...

Incident ID : TB1717779G



Reproducible: Always
Steps to Reproduce:
0. Themes should be modern (by default ?)
1. Open location http://bugzilla.mozilla.org/
2. Change theme to classic
3. Change theme to modern (crash here)


Actual Results:  crash

Expected Results:  didn't crash

Comment 1

17 years ago
CC: stephend@netscape.com, for talkback retrieval, please (TB1717779G)

Probably dupe of bug 117386, which is fixed in a later build.
Keywords: crash

Comment 2

17 years ago
Seems reproductible on MacosX build ID 2002011608.
To reproduce open mozilla open a new tab load slashdot in that tab. switch
themes onec or twice => bang crashes ...
OS -> ALL
Platform -> ALL
nsLineLayout::IsPercentageUnitSides()
IsPercentageAwareChild()
nsBlockFrame::ReflowInlineFrame()
nsBlockFrame::DoReflowInlineFrames()
nsBlockFrame::DoReflowInlineFramesAuto()
nsBlockFrame::ReflowInlineFrames()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableCellFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableRowFrame::ReflowChildren()
nsTableRowFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableRowGroupFrame::ReflowChildren()
nsTableRowGroupFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableFrame::ReflowChildren()
nsTableFrame::ReflowTable()
nsTableFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableOuterFrame::OuterReflowChild()
nsTableOuterFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsContainerFrame::ReflowChild()
CanvasFrame::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::DoLayout()
nsBox::Layout()
nsScrollBoxFrame::DoLayout()
nsBox::Layout()
nsContainerBox::LayoutChildAt()
nsGfxScrollFrameInner::LayoutBox()
nsGfxScrollFrameInner::Layout()
nsGfxScrollFrame::DoLayout()
nsBox::Layout()
nsBoxFrame::Reflow()
nsGfxScrollFrame::Reflow()
nsContainerFrame::ReflowChild()
ViewportFrame::Reflow()
PresShell::ResizeReflow()
PresShell::ResizeReflow()
nsViewManager::SetWindowDimensions()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::OnResize()
nsWindow::Resize()
nsView::SetDimensions()
nsViewManager::SetWindowDimensions()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::OnResize()
nsWindow::Resize()
nsWindow::Resize()
DocumentViewerImpl::SetBounds()
nsDocShell::SetPositionAndSize()
nsHTMLFrameInnerFrame::Reflow()
nsContainerFrame::ReflowChild()
nsHTMLFrameOuterFrame::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::DoLayout()
nsBox::Layout()
nsStackLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsDeckFrame::DoLayout()
nsBox::Layout()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout() 

Comment 4

17 years ago
Stack same as 115919

*** This bug has been marked as a duplicate of 115919 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.