Closed Bug 1202567 Opened 5 years ago Closed 5 years ago

test_waveShaperInvalidLengthCurve.html fails with runByDir enabled

Categories

(Core :: Audio/Video: MediaStreamGraph, defect)

43 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1187204
Tracking Status
firefox43 --- affected

People

(Reporter: kaustabh93, Unassigned)

References

Details

Here's a link of a push : https://treeherder.mozilla.org/#/jobs?repo=try&revision=92b9646d31a6&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified&filter-searchStr=xp
These, failures were obtained while bisecting another directory, dom/media/test.
00:55:31  WARNING -  TEST-UNEXPECTED-FAIL | dom/media/webaudio/test/test_waveShaperInvalidLengthCurve.html | application terminated with exit code 1
00:55:31     INFO -  runtests.py | Application ran for: 0:01:24.374000
00:55:31     INFO -  zombiecheck | Reading PID log: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpo0bntqpidlog
00:55:44     INFO -  mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\76f7f54f-aca8-489b-8551-dc250d1c9f30.dmp
00:55:44     INFO -  mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\76f7f54f-aca8-489b-8551-dc250d1c9f30.extra
00:55:44  WARNING -  PROCESS-CRASH | dom/media/webaudio/test/test_waveShaperInvalidLengthCurve.html | application crashed [@ mozilla::AssertNotAlreadyCached]
Blocks: 1162003
Don't really know what's going on here, maybe padenot who mentored me on this bug will.

The interesting part of the log is the following:

 00:55:30 INFO - Attempt to add a bool pref cache for preference 'dom.audiochannel.mutedByDefault' at address '06C6F630'was made. However, a pref was already cached at this address.
00:55:31 INFO - Assertion failure: false (Should not have an existing pref cache for this address), at c:/builds/moz2_slave/try-w32-d-00000000000000000000/build/src/modules/libpref/Preferences.cpp:216
00:55:31 INFO - #01: mozilla::Preferences::AddBoolVarCache(bool *,char const *,bool) [modules/libpref/Preferences.cpp:1745]
00:55:31 INFO - #02: mozilla::dom::AudioChannelService::AudioChannelService() [dom/audiochannel/AudioChannelService.cpp:227]
00:55:31 INFO - #03: mozilla::dom::AudioChannelService::GetOrCreate() [dom/audiochannel/AudioChannelService.cpp:170]
00:55:31 INFO - #04: mozilla::dom::AudioChannelAgent::NotifyStoppedPlaying(unsigned int) [dom/audiochannel/AudioChannelAgent.cpp:159]
00:55:31 INFO - #05: mozilla::dom::AudioDestinationNode::DestroyAudioChannelAgent() [dom/media/webaudio/AudioDestinationNode.cpp:391]
00:55:31 INFO - #06: mozilla::dom::AudioNode::cycleCollection::Unlink(void *) [dom/media/webaudio/AudioNode.cpp:25]
00:55:31 INFO - #07: mozilla::dom::AudioDestinationNode::cycleCollection::Unlink(void *) [dom/media/webaudio/AudioDestinationNode.cpp:313]
00:55:31 INFO - #08: nsCycleCollector::CollectWhite() [xpcom/base/nsCycleCollector.cpp:3276]
00:55:31 INFO - #09: nsCycleCollector::Collect(ccType,js::SliceBudget &,nsICycleCollectorListener *,bool) [xpcom/base/nsCycleCollector.cpp:3630]
00:55:31 INFO - #10: nsCycleCollector::ShutdownCollect() [xpcom/base/nsCycleCollector.cpp:3548]
00:55:31 INFO - #11: nsCycleCollector_shutdown() [xpcom/base/nsCycleCollector.cpp:4164]
00:55:31 INFO - #12: mozilla::ShutdownXPCOM(nsIServiceManager *) [xpcom/build/XPCOMInit.cpp:952]
00:55:31 INFO - #13: ScopedXPCOMStartup::~ScopedXPCOMStartup() [toolkit/xre/nsAppRunner.cpp:1498]
00:55:31 INFO - #14: mozilla::DefaultDelete<ScopedXPCOMStartup>::operator()(ScopedXPCOMStartup *) [mfbt/UniquePtr.h:490]
00:55:31 INFO - #15: XREMain::XRE_main(int,char * * const,nsXREAppData const *) [toolkit/xre/nsAppRunner.cpp:4416]
00:55:31 INFO - #16: XRE_main [toolkit/xre/nsAppRunner.cpp:4478]
00:55:31 INFO - #17: do_main [browser/app/nsBrowserApp.cpp:212]
00:55:31 INFO - #18: NS_internal_main(int,char * *) [browser/app/nsBrowserApp.cpp:399]
00:55:31 INFO - #19: wmain [toolkit/xre/nsWindowsWMain.cpp:138]
00:55:31 INFO - #20: __tmainCRTStartup [f:/dd/vctools/crt/crtw32/startup/crt0.c:255]
00:55:31 INFO - #21: kernel32 + 0x17067
00:55:31 INFO - TEST-INFO | Main app process: exit 1 


see also https://dxr.mozilla.org/mozilla-central/source/dom/audiochannel/AudioChannelService.cpp#231-232
Flags: needinfo?(padenot)
Component: Audio/Video → Audio/Video: MSG/cubeb/GMP
Blocks: 1202565
I'm not clear either, but some things to think about:

I guess it is not desirable to create the AudioChannelService during shutdown.

Not sure, but I wonder whether it would be practical to call DestroyAudioChannelAgent() earlier than Unlink(), because it wouldn't be unlinked if it were still playing.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(padenot)
Resolution: --- → DUPLICATE
Duplicate of bug: 1187204
You need to log in before you can comment on or make changes to this bug.