Menues are black font on black background

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Roman Fiedler, Unassigned)

Tracking

Trunk
seamonkey2.41
x86
Linux

SeaMonkey Tracking Flags

(seamonkey2.39 affected, seamonkey2.41 fixed)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39a1
Build ID: 20150801003001

Steps to reproduce:

Install the latest nightly for Linux i686 from https://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/ (build 20150801) on Ubuntu Trusty.

Click on any menu bar item or right click on links.


Actual results:

Menu opens, normal text is black on black, disabled items are grey on black.


Expected results:

Menu background should be light grey.

Updated

2 years ago
OS: Unspecified → Linux
Summary: Menues are black font on black background with latest nightly → Menues are black font on black background
Version: Trunk → SeaMonkey 2.39 Branch

Comment 1

2 years ago
I suspect the move from GTK2 to GTK3 is the cause.

Comment 2

2 years ago
Bug 1176109 - Popup menu text is too dark on some GTK3 themes
This is supposedly fixed in mozilla42.
Try choosing a different GTK3 theme

Comment 3

2 years ago
NOT reproducible with  German SeaMonkey 2.41a1  (X11; Linux x86_64; rv:44.0)  Gecko/20100101 Firefox/44.0 Build 20151029003002  (Classic Theme or "Modern") on VirtualBox Ubuntu 14

@reporter: 
can yo confirm Philip Chee's assumption?
Flags: needinfo?(roman.fiedler)
(Reporter)

Comment 4

2 years ago
Issue seems to be fixed at least after 2015-09-30 in trunk, so not reproducible here any more also (seamonkey-2.41a1.en-US.linux-i686)
Flags: needinfo?(roman.fiedler)
Resolving WORKSFORME on the basis of comment #32. 2.41 is now Aurora. The fix may still need to be ported to Beta and Release, or at worst it will follow the Release Train.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
status-seamonkey2.39: --- → affected
status-seamonkey2.41: --- → fixed
Hardware: Unspecified → x86
Resolution: --- → WORKSFORME
Version: SeaMonkey 2.39 Branch → Trunk
oops, ...of comment #4.
Target Milestone: --- → seamonkey2.41
You need to log in before you can comment on or make changes to this bug.