If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

test_udpsocket.js fails on Linux locally

RESOLVED INVALID

Status

()

Core
Networking
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: ethan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Version   : Firefox 43.0a1
Build ID  : 20150908111149
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
PC        : Ubuntu 14.04 TLS

Steps to Reproduce:
1. I pull the latest code from mozilla-central (changeset: 5fe9ed3edd68)
2. Run ./mach build
3. Execute xpcshell unit tests in netwerk folder
   ./mach xpcshell-test <path-to-repo>/mozilla-central/netwerk/test/unit/test_udpsocket.js

Expected Result:
The test script should pass.

Actual Result:
FAIL [Parent]
netwerk/test/unit/testsocket.js
(Reporter)

Comment 1

2 years ago
(In reply to Ethan Tseng [:ethan] from comment #0)
> Actual Result:
> FAIL [Parent]
> netwerk/test/unit/testsocket.js
                    ^^^^^^^^^^
Typo. Should be:
netwerk/test/unit/test_udpsocket.js
(Reporter)

Comment 2

2 years ago
Created attachment 8658087 [details]
bug-1202596.log

Output logs.
(Reporter)

Comment 3

2 years ago
*** Notes ***
1. This test failure does not happen on Mac OS, and not on Treeherder either.
   It only happens on Linux locally.
2. I think this is a recent regression because I didn't see this failure last week while running
   xpcshell tests under netwerk/test/unit.
3. The log shows a "Harness FAIL" message, which could be a clue.
   But I don't know how to trace this issue.
(Reporter)

Updated

2 years ago
See Also: → bug 1202589
(Reporter)

Comment 4

2 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=1202589#c7
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.