The order of RefreshDriver::Tick() for chrome and content is unpredictable

RESOLVED DUPLICATE of bug 1210261

Status

()

RESOLVED DUPLICATE of bug 1210261
3 years ago
3 years ago

People

(Reporter: hiro, Unassigned)

Tracking

Other Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In current implementation, the order of Tick on each vsync [1] is indefinite. I think root refresh driver should tick after all other refresh drivers ticked because the root refresh driver does DO a paint. 
 
[1] http://hg.mozilla.org/mozilla-central/file/5fe9ed3edd68/layout/base/nsRefreshDriver.cpp#l182
(Reporter)

Comment 1

3 years ago
The order has been fixed in bug 1210261.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210261
You need to log in before you can comment on or make changes to this bug.