[v2.5][Gaia::UI Tests]test_gallery_edit_photo.py:"AssertionError: 2 != 0"

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Lance(leave from Mozilla), Assigned: Martijn Wargers (dead))

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
[Description]
test_gallery_edit_photo.py fails

[Steps to Reproduce]
test_gallery_edit_photo.py

[Reproduction Frequency]
Always, 5/5

Traceback (most recent call last):
File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_edit_photo.py", line 43, in test_gallery_edit_photo
self.assertEqual(2, gallery.gallery_items_number)
AssertionError: 2 != 0

[Build info]
Device firmware (base) 	L1TC000118D0
Device firmware (date) 	07 Sep 2015 19:05:10
Device firmware (incremental) 	eng.cltbld.20150907.070457
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	07 Sep 2015 10:49:56
Gaia revision 	891798f1e345
Gecko build 	20150907030329
Gecko revision 	5fe9ed3edd6811a662d40d05e37b0d66e9520d82
Gecko version 	43.0a1

[Attachments]
Non-smoketest report
(Reporter)

Updated

2 years ago
status-b2g-master: --- → affected
(Reporter)

Comment 1

2 years ago
Created attachment 8658105 [details]
20150907030329-NONSMOKETEST.html
(Assignee)

Comment 2

2 years ago
It used to be that after saving an edited image, you would go back to the thumbnails list. Nowadays you get to see the fullscreen view of the edited image.

Apparently, this was fixed in bug 1148347. See comments in the pull request.
It's weird, though, because that bug was fixed at 2015-08-14, which is 3 weeks ago!
Assignee: nobody → martijn.martijn
Blocks: 1148347
(Assignee)

Comment 3

2 years ago
Also an issue with:
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_crop_photo.py#32

Comment 4

2 years ago
Created attachment 8658239 [details] [review]
[gaia] mwargers:1202602 > mozilla-b2g:master
(Assignee)

Comment 5

2 years ago
Comment on attachment 8658239 [details] [review]
[gaia] mwargers:1202602 > mozilla-b2g:master

Btw, I occasionally got this failure, still, after this patch:
TEST-UNEXPECTED-ERROR | test_gallery_crop_photo.py TestGalleryCropPhoto.test_gallery_crop_photo | TimeoutException: TimeoutException: Timed out after 10.1 seconds


Traceback (most recent call last):
  File "/Users/mwargers/.virtualenvs/test3/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_crop_photo.py", line 32, in test_gallery_crop_photo
    image = edit_image.tap_edit_save_button()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/edit_photo.py", line 50, in tap_edit_save_button
    Wait(self.marionette).until(expected.element_displayed(element))
  File "/Users/mwargers/.virtualenvs/test3/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 92408ms

SUMMARY
-------
passed: 0
failed: 1
todo: 0

This seems to be happening when the crop buttons are available before the image is available, which then causes the various crop buttons to not respond to what they should be doing.
I guess this is a case of a "Gaia UI test is running so quickly, which is uncovering errors on the slow Flame device" bug.
I guess I need to file a new bug for that.
Attachment #8658239 - Flags: review?(npark)
Attachment #8658239 - Flags: review?(jlorenzo)
(Assignee)

Updated

2 years ago
Blocks: 1202805
Comment on attachment 8658239 [details] [review]
[gaia] mwargers:1202602 > mozilla-b2g:master

Good to know, actually, could you do me a favor and make change here as well please?
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/graphics/edit_picture_base.py#93
Thanks!
Attachment #8658239 - Flags: review?(npark) → review+
(Assignee)

Comment 7

2 years ago
(In reply to No-Jun Park [:njpark] from comment #6)
> Good to know, actually, could you do me a favor and make change here as well
> please?
> http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/
> graphics/edit_picture_base.py#93
> Thanks!

Done.
Comment on attachment 8658239 [details] [review]
[gaia] mwargers:1202602 > mozilla-b2g:master

The changes are good.

After a `git grep tap_edit_save_button`, there is no other place we have to modify.

Side note: Once the switches buttons are factorized, I think the next step of the factorization should be the header. I filed bug 1203456, in this regard.
Attachment #8658239 - Flags: review?(jlorenzo) → review+
Concerning comment 5, I agree this looks like a product issue, to me too.
(Assignee)

Comment 10

2 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/6280500a6cb8d1b178cdd163450e36d22846fbed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

2 years ago
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #9)
> Concerning comment 5, I agree this looks like a product issue, to me too.

I filed bug 1203504 as a follow-up.
You need to log in before you can comment on or make changes to this bug.