Closed Bug 1202613 Opened 5 years ago Closed 2 years ago

Extreme slow-down of logon/logoff with roaming profiles in windows 7 after Lightning update from AMO (caused by thousands of language-related files?)

Categories

(Calendar :: General, defect)

Lightning 4.0.2
x86_64
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: susi_s0rglos, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [dupeme?])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/600.8.9 (KHTML, like Gecko) Version/7.1.8 Safari/537.85.17

Steps to reproduce:

Install Thunderbird 38.0.1 which includes Lightning 4.0.0.1
Start Thunderbird and choose to accept calendar integration and keep Lightning
Check size of folder {e2fda1a4-762b-4020-b5ad-a41df1933103} in user's profile is 90 files in 6 folders
Use Thunderbird built-in update mechanism to update Lightning to latest version (4.0.2)
Check size of folder {e2fda1a4-762b-4020-b5ad-a41df1933103} in user's profile grew to 2044 files in 561 folders
The amount of 2044 files in 561 folders seems to be due to each and every language known being installed for Lightning


Actual results:

Initially, the size of folder {e2fda1a4-762b-4020-b5ad-a41df1933103} in user's profile is 90 files in 6 folders. After update, it grows to 2044 files in 561 folders.

Problems:
For users with a roaming profile on windows 7, logon/logoff is severely slowed down by the amount of files/folders now in the user's profile folder

Startup of Thunderbird is also slowed down albeit less


Expected results:

The size of the folder {e2fda1a4-762b-4020-b5ad-a41df1933103} should remain approximately the same across updates
Just to give an idea of the magnitude of the problem: On logoff the time spent roaming the user's profile (Please wait for the User Profile Service...) increases by a factor of three from about 8 seconds to 25 seconds. On logon the time doubles (writing to the local HD is faster than to the profile server).
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
I have experienced the same problem. I tried Lightning when it was integrated into Thunderbird. Couldn't use it because it slowed down Thunderbird by at least an order of magnitude. I shut it off. Today I upgraded to 38.3.0 and it turned Lightning back on again without my permission, thus slowing things down terribly. I removed the Lightning add-on and things are back to speedy again. I don't believe a roaming profile will make the problem significantly different. I have a pretty quick machine and it still crawls with Lightning turned on.
What account has long login times - a calendar account?  Or a mail account?
Flags: needinfo?(susi_s0rglos)
Keywords: perf
The logon to windows is slowed down, more precisely, roaming the user's profile takes longer because of the number of directories and files installed when updating lightning.
Flags: needinfo?(susi_s0rglos)
(In reply to susi_s0rglos from comment #4)
> The logon to windows is slowed down, more precisely, roaming the user's
> profile takes longer because of the number of directories and files
> installed when updating lightning.

So the profile is stored somewhere outside the PC?
What file system?
Flags: needinfo?(susi_s0rglos)
Yep, that's the nature of roaming profiles. Profile (changed portions actually) is copied in from profile server on logon and back on logoff. File system ntfs.
Flags: needinfo?(susi_s0rglos)
(In reply to susi_s0rglos from comment #6)
> Yep, that's the nature of roaming profiles. Profile (changed portions
> actually) is copied in from profile server on logon and back on logoff. File
> system ntfs.

Sure. Just want to make sure we are totally on the same page :)
Summary: Extreme slow-down of logon/logoff with roaming profiles in windows 7 after Lightning update → Extreme slow-down of logon/logoff with roaming profiles in windows 7 after Lightning update from AMO (caused by thousands of language-related files?)
Whiteboard: [dupeme?]
Should this issue be gone now that add-ons are not unpacked?
Severity: normal → major
Flags: needinfo?(geoff)
I would say so, yes.
Flags: needinfo?(geoff)
susi, this should no longer be an issue, I think with bug 1406499
If you still see a problem when using version 60, please update the bug. thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Depends on: 1406499
Resolution: --- → WORKSFORME
Duplicate of this bug: 1192578
You need to log in before you can comment on or make changes to this bug.