Intermittent browser_private_clicktoplay.js | Test timed out - expected PASS

RESOLVED FIXED in Firefox 50

Status

()

defect
P3
normal
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: cbook, Assigned: mrbkap)

Tracking

({intermittent-failure})

unspecified
mozilla52
Points:
---

Firefox Tracking Flags

(firefox50 fixed, firefox51 fixed, firefox52 fixed)

Details

()

Attachments

(1 attachment, 1 obsolete attachment)

https://treeherder.mozilla.org/logviewer.html#?job_id=13775541&repo=mozilla-inbound

 02:40:21 INFO - 104 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/plugins/browser_private_clicktoplay.js | Test timed out - expected PASS
Component: General → Plug-ins
Product: Firefox → Core
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
I guess no good deed goes unpunished. This appears to have spiked on all branches after bug 1304531 landed on them. It's mostly affecting e10s runs, though there have been a couple non-e10s one as well.
Flags: needinfo?(mrbkap)
I suspect this spiked because (possibly? I hope?) on runs where we would have failed earlier thanks to other CPOW uses. Another possibility is that shim that the harness used to use and now doesn't was changing the timing, causing this to pass when it would have otherwise failed.
Assignee: nobody → mrbkap
Flags: needinfo?(mrbkap)
Comment on attachment 8798620 [details]
Bug 1202623 - Attempt to fix this intermittent orange by removing CPOWs from the test and moving to more solid test infrastructure.

https://reviewboard.mozilla.org/r/84044/#review83154
Attachment #8798620 - Flags: review?(felipc) → review+
Pushed by mrbkap@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b4b85729bcf3
Attempt to fix this intermittent orange by removing CPOWs from the test and moving to more solid test infrastructure. r=felipe
https://hg.mozilla.org/mozilla-central/rev/b4b85729bcf3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
https://hg.mozilla.org/releases/mozilla-aurora/rev/1f6b193ff8be
Whiteboard: [checkin-needed-aurora][checkin-needed-beta] → [checkin-needed-beta]
has problems uplifting to beta:

grafting 369274:1f6b193ff8be "Bug 1202623 - Attempt to fix this intermittent orange by removing CPOWs from the test and moving to more solid test infrastructure. r=felipe, a=test-only"
merging browser/base/content/test/plugins/browser_private_clicktoplay.js
warning: conflicts while merging browser/base/content/test/plugins/browser_private_clicktoplay.js! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(mrbkap)
Was a silly conflict caused by a whitespace-only eslint fix.

https://hg.mozilla.org/releases/mozilla-beta/rev/1cd295569b2bd7b40cab83c179525fd549c73051
Flags: needinfo?(mrbkap)
Whiteboard: [checkin-needed-beta]
this is still showing up on v.51 and v.52
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8798620 - Attachment is obsolete: true
Comment on attachment 8798619 [details]
Bug 1202623 - Try to fix the intermittent orange by listening earlier for the notification.

https://reviewboard.mozilla.org/r/84042/#review90202
Attachment #8798619 - Flags: review?(felipc) → review+
Pushed by mrbkap@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e8e4c0bfd0b
Try to fix the intermittent orange by listening earlier for the notification. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/4e8e4c0bfd0b
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.