WebGL makes e10s windows crash on Xwayland

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Emmanuel Gil Peyrot, Unassigned)

Tracking

43 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150908030203

Steps to reproduce:

Start Weston, or any other Wayland compositor, with Xwayland support.
Run Firefox Nightly with e10s enabled.
Open any page containing WebGL, like http://get.webgl.org/


Actual results:

The e10s process crashed: https://crash-stats.mozilla.com/report/index/e89542f0-2a5a-4515-bcaf-bb5112150908


Expected results:

The page would have loaded and rendered correctly.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
I should also note that this works properly in a non-e10s window.
tracking-e10s: --- → +
Component: Untriaged → Graphics
Product: Firefox → Core
Whiteboard: [gfx-noted]

Comment 2

2 years ago
Hi Emmanuel,

I don't have the proper environment for testing this issue, but can you tell us if you still have this problem on the latest Firefox Nightly? Please download Nightly from here: https://nightly.mozilla.org/ and retest the problem. Also if it crashes please provide the crash ID. Thank you for your time.
Flags: needinfo?(bugs)
(Reporter)

Comment 3

2 years ago
On latest 47.0a1 I can’t reproduce that crash anymore, on the same environment.

Let me know if you prefer me to bisect, but I’m closing this bug as it now works, thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bugs)
Resolution: --- → WORKSFORME
This may have been fixed by bug 1241832, which removed our remaining interactions with xrender.
You need to log in before you can comment on or make changes to this bug.