Console message not being shown with e10s

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
Last year

People

(Reporter: bbouvier, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

STR:
- open a new tab
- open the dev tools console (ctrl shift K)
- go to http://bugfirefox.benj.me/

Expected:
- error message "no element found        write:1:1" shows up in the console

Observed:
- with e10s enabled, it doesn't show up there (nor does it in the browser console)
- when e10s is disabled, it does show up in the consoles (devtools + browser)

It's probably related to bug 1194710 (either a cause or a consequence), but I can't tell how. It'd be nice if a pair of devtools hacker's eyes could have a look at this.
I was able to reproduce 100% on nightly. Patric, who would be a good person to assign this bug to?
Flags: needinfo?(pbrosset)
Honestly I don't know, and I can't help with this issue.
Panos might know better.
Flags: needinfo?(pbrosset) → needinfo?(past)
It seems that the XML parsing error that we get in single-process mode doesn't get to the ConsoleServiceListener in e10s mode. I've instrumented CSL_observe and it never gets called. The error message I believe is triggered in nsExpatDriver::HandleError (it's the only instance of "malformed-xml" that I see in the tree. 

I don't have time to investigate further right now, but we need to figure out if the error is being created and doesn't reach the console listener or not.
Blocks: dte10s
tracking-e10s: --- → ?
Flags: needinfo?(past)
Benjamin, is this still an issue? I don't see a "no element found        write:1:1" error message, with or without e10s. I tested FF 44 and 47.
Flags: needinfo?(bbouvier)
I've relaunched the server mentioned in comment 0, and it looks like this has been fixed at some point. Closing as worksforme, but I will let the server running a few days, in case somebody wants to bisect the fix.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bbouvier)
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.