Closed Bug 1202819 Opened 5 years ago Closed 5 years ago

Installing Fennec build environment fails in Linux

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1114718

People

(Reporter: karanjai.moz, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.155 Safari/537.36

Steps to reproduce:

Tried to prepare a build environment in a vanilla Arch linux with both wget and curl following https://wiki.mozilla.org/Mobile/Fennec/Android#Building_Fennec


Actual results:

Got an error in both of them in the build script urging me to file a bug


Expected results:

It should have installed and configured build environment
Suggested change:

If we change include parenthesis "()" in the acrhlinux.py file in mozbot. This should work. Apparently this is happening because I have python 3. And that file uses python 2.7 conventions
The whole bootstrap script is for python 2.7 and won't work with python 3.
(In reply to Mike Hommey [:glandium] from comment #2)
> The whole bootstrap script is for python 2.7 and won't work with python 3.

Got that. And made it to work on mine. But apparently the present bootstrap cannot handle installation of fennec (for android) in arch linux.
So even without this....it was still a fail
Android setup is not implemented in bootstrap. You will need to create your environment manually. I recommend running boostrap as suggested for Firefox desktop development and dealing with the Java/Android SDK/NDK as outlined in https://wiki.mozilla.org/Mobile/Fennec/Android/Detailed_build_instructions#Linux
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1114718
To be clear bootstrap is only supported on Ubuntu/Debian. For Arch Linux someone would need to provide the code, https://dxr.mozilla.org/mozilla-central/source/python/mozboot/mozboot/archlinux.py?offset=300#78 and the older bug 1114718.
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.