Earlybird 42a2 email text from Outlook hidden by Lightning 4.4a2

RESOLVED FIXED in 4.4

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Murray Treloar, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 4.4
x86
Windows 8.1
regression

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Disabled all addons - no bug; Re-enabled Lightning; Bug re-appeared


Actual results:

An invitation sent from an Outlook user showed meeting info when Lightning diabled; Message body is empty when Lightning is enabled


Expected results:

In TBird 38 (release version), the message body shows the invitation detail
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86
(Reporter)

Comment 1

2 years ago
Additional info: Addon "Show All Body Parts" shows the message content, and adds 3 attachments, one is an *.ics file. Reverting to View Body as Original HTML reverts to blank message text and removes the attachments
(Assignee)

Comment 2

2 years ago
Can you please check whether you have any messages in the error log (ctrl+shift+j) when getting displayed the empty body?
Component: Mail Window Front End → E-mail based Scheduling (iTIP/iMIP)
Flags: needinfo?(mtreloar)
Product: Thunderbird → Calendar
Version: 42 → Lightning 4.4
(Reporter)

Comment 3

2 years ago
No error messages or any other messages.  Is there a setting I need to turn "on" other than in the Error Console in order to collect errors/messages in the log? I have the "All" set on in the Error Console?
Flags: needinfo?(mtreloar)
(Assignee)

Comment 4

2 years ago
Please enable calendar.debug.log and calendar.debug.log.verbose in the config editor and try again. Can you please also attach the email in question?

And just to be sure: you're expiriencing the problem with Lightning only but no further addons, correct?
Flags: needinfo?(mtreloar)
(Reporter)

Comment 5

2 years ago
Thanks for the tips - novice here.  And yes, Lightning as only addon causes the problem.  I do not see an "attach" option on this site. May I send you a PM at makemyday@gmx-topmail.de?
Flags: needinfo?(mtreloar)
(Assignee)

Comment 6

2 years ago
There is an add attachment link above. Please choose plain/text type when attaching.
(Assignee)

Comment 7

2 years ago
If you want to provide it by mail, please make sure you send it as attachment.
Flags: needinfo?(mtreloar)
(Reporter)

Comment 8

2 years ago
Sent by mail. My apologies for sending 5 messages when 1 or 2 would do.
Flags: needinfo?(mtreloar)
(Reporter)

Comment 9

2 years ago
Created attachment 8658786 [details]
Bug 1202901 Body as all Body Parts visible
(Reporter)

Comment 10

2 years ago
Created attachment 8658787 [details]
Bug1202901 Body as original html
(Reporter)

Updated

2 years ago
Attachment #8658787 - Attachment description: Bug1202901 Body as All Body Parts ON - Shows content → Bug1202901 Body as original html
(Reporter)

Updated

2 years ago
Attachment #8658786 - Attachment description: Bug 1202901 Body as Original HTML (blank) → Bug 1202901 Body as all Body Parts visible
(Assignee)

Updated

2 years ago
Attachment #8658786 - Attachment mime type: message/rfc822 → text/plain
(Assignee)

Updated

2 years ago
Attachment #8658787 - Attachment mime type: message/rfc822 → text/plain
(Assignee)

Comment 11

2 years ago
Thanks. Have you also checked the error lig after enabling debug mode?
(Reporter)

Comment 12

2 years ago
OK.  I have set:
calendar.debug.log           user set  boolean   true
calendar.debug.log.verbose   user set  boolean   true

And there are errors now.  How do I export the log file?  I assume you want it as an attachment here.

Comment 13

2 years ago
When I try to open the attached test case in Thunderbird 43.0a1 (20150909030202) I get the following errors: 

> Error: TypeError: getIdentityForHeader(...) is null
> Source File: chrome://messenger/content/mailWindowOverlay.js Line: 1189
> 
> Error: not well-formed
> Source Code:
> Join the meeting<https://www147.livemeeting.com/cc/_XML/cerner/join?id=FSN5MR&role=attend&pw=6D9J%5B%60c>
> 
> Error: [ltnMimeConverter] convertToHTML: SyntaxError: An invalid or illegal string was specified
> Source File: file:///[...]/components/lightningTextCalendarConverter.js Line: 85

Comment 14

2 years ago
lightningTextCalendarConverter.js was changed with Bug 533265 in Lightning 4.4, maybe this a regression from this check-in. Maybe problem like not escaping control characters (like "<" or ">") when entering the message content into the new html structure and therefore causing some invalid html syntax.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 15

2 years ago
The error is thrown in function field() in ltnInvitationUtils.jsm when called for "description" field when trying to store the result of linkConverter.scanHTML() to content.innerHTML.

Comment 16

2 years ago
Looks like the problem could be fixed by calling linkConverter.scanTXT(aContentText, Components.interfaces.mozITXTToHTMLConv.kEntities) first to escape "<", ">" and "&" before passing the result to linkConverter.scanHTML().
(Assignee)

Comment 17

2 years ago
Created attachment 8658873 [details] [diff] [review]
FixHtmlConversion-V1.diff

Thanks Stefan for already looking into this - your proposed solution is the appropriate approach to fix the issue.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Attachment #8658873 - Flags: review?(philipp)
(Assignee)

Updated

2 years ago
Keywords: regression

Comment 18

2 years ago
Do we already have a unit test for ltnInvitationUtils.jsm where we could add this testcase? If not, could we create one? :)

Updated

2 years ago
Blocks: 533265
(Assignee)

Comment 19

2 years ago
Actually, we haven't. I'm currently working on another patch modifying functionality of lrnInvitationUtils.jsm and will consider to have a unit test for the same starting with that patch.
Attachment #8658873 - Flags: review?(philipp) → review+
I'd prefer a unit test for this, but I understand that writing it won't be simple so I'll leave that up to you.
(Assignee)

Comment 21

2 years ago
I plan to start adding unit tests for ltnbInvitationUtils.jsm with bug 1174511, so I leave this patch without.
Keywords: checkin-needed

Updated

2 years ago
Attachment #8658873 - Flags: approval-calendar-aurora?(philipp)

Comment 22

2 years ago
https://hg.mozilla.org/comm-central/rev/5e95881b6b2511415a53c349b65c08513979f582
Bug 1202901 - Earlybird 42a2 email text from Outlook hidden by Lightning 4.4a2. r=philipp a=aleth

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 4.6
(Assignee)

Comment 23

2 years ago
Comment on attachment 8658873 [details] [diff] [review]
FixHtmlConversion-V1.diff

After the latest merge, this patch needs to go to beta as well.
Attachment #8658873 - Flags: approval-calendar-beta?(philipp)
Attachment #8658873 - Flags: approval-calendar-beta?(philipp)
Attachment #8658873 - Flags: approval-calendar-beta+
Attachment #8658873 - Flags: approval-calendar-aurora?(philipp)
Attachment #8658873 - Flags: approval-calendar-aurora+
Backported to releases/comm-beta changeset b508a45a0ba5
Target Milestone: 4.6 → 4.4
https://hg.mozilla.org/releases/comm-aurora/rev/a23b24584182
You need to log in before you can comment on or make changes to this bug.