[Dialer] Call banner is white (the banner that appears on top when pressing Home button while in a call)

VERIFIED FIXED

Status

Firefox OS
Gaia::System::Window Mgmt
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: piwei, Assigned: etienne)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing], [spark][2.5-aries-test-run-2])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8658425 [details]
logcat of issue

Description:
The call banner that temporarily displays on top of screen when user presses Home button while in an active call is white. It doesn't break its functionality though; user can still access callscreen tapping on that white call banner.

STR:
1) On DUT, receive a call or make a call, and make the call connected
2) Press home while in an active call

Expected: Call banner appears normally

Actual: Call banner is white.

Repro rate: 5/5

Video showing the issue:
https://www.youtube.com/watch?v=_-8ZEAm1sWc

Attaching a logcat.

Issue reproduces on:

Device: Aries 2.5
BuildID: 20150908152248
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
BuildID: 20150908063734
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
(Reporter)

Comment 1

3 years ago
Flame 2.2 is unaffected. Call banner is displayed correctly.

Device: Flame 2.2
BuildID: 20150908032505
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 96170c571381
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.5-Daily-Testing], [spark]
[Blocking Requested - why for this release]:
Regression in Dialer.  Let's get a window here.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
Comms triage: Broken functionality.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P1
Whiteboard: [2.5-Daily-Testing], [spark] → [2.5-Daily-Testing], [spark][2.5-aries-test-run-2]
Bizarre but this is not a callscreen bug, we didn't land anything since the 29th of August, I suspect a system app bug.
BTW I'm bisecting this since I've got a good idea of the window already.
This was caused by commit 7d20d898e826b9fe6d2119d33616d80e44bf17de, bug 1201099. Moving in the right component and handing over to Etienne.
Component: Gaia::Dialer → Gaia::System::Window Mgmt
Flags: needinfo?(etienne)
Keywords: regressionwindow-wanted
(Assignee)

Comment 7

3 years ago
Thanks for the investigation!
Assignee: nobody → etienne
Flags: needinfo?(etienne)
(Assignee)

Updated

3 years ago
Depends on: 1201099
Created attachment 8659167 [details] [review]
[gaia] etiennesegonzac:bug-1202909 > mozilla-b2g:master
(Assignee)

Comment 9

3 years ago
Comment on attachment 8659167 [details] [review]
[gaia] etiennesegonzac:bug-1202909 > mozilla-b2g:master

Small patch, missed a case earlier.
Attachment #8659167 - Flags: review?(im)
Comment on attachment 8659167 [details] [review]
[gaia] etiennesegonzac:bug-1202909 > mozilla-b2g:master

Looks good to me. Thanks.
Attachment #8659167 - Flags: review?(im) → review+
Duplicate of this bug: 1203761
(Assignee)

Comment 12

3 years ago
https://github.com/mozilla-b2g/gaia/commit/758c75ee087ea3722213ea2c185cca1d952c8a29

:')
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: When the Call banner appears on top when pressing Home button while in a call, it is blue and shows talk time.
See attachment: verified_Flame_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150913150208
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150913.184300
Firmware Date          Sun Sep 13 18:43:14 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150913195924
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150913.192006
Firmware Date          Sun Sep 13 19:20:14 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8660542 [details]
verified_Flame_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.