in chat, urls delimited by inferior/superior are not parsed correctly

RESOLVED DUPLICATE of bug 954848

Status

Thunderbird
Instant Messaging
RESOLVED DUPLICATE of bug 954848
2 years ago
2 years ago

People

(Reporter: Pascal Bourguignon, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

1- Join some irc chat channe.  A good example is irc://irc.freenode.org/#hn
2- Receive  some url enclosed in inferior/superior. 

Alternatively:

1- /join #test
2- send: This is a test: <http://www.bugzilla.org/> RET


Actual results:

You receive the corresponding message, with the url parsed with the ">" included in the url:

02:34:05 - ogamita: This is a test: <[http://www.bugzilla.org/>];

If you click on it, you go to <http://www.bugzilla.org/%3E> instead of <http://www.bugzilla.org/>.


Expected results:

The URL should have be identified correctly:

02:34:05 - ogamita: This is a test: <[http://www.bugzilla.org/]>;

If you clicked on it, you would go to <http://www.bugzilla.org/>.

Updated

2 years ago
Component: Untriaged → Instant Messaging
This is essentially the same as bug 954848.

I believe the relevant code is actually chat core (calling into a m-c component): http://mxr.mozilla.org/comm-central/source/chat/content/convbrowser.xml#499
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 954848
You need to log in before you can comment on or make changes to this bug.