Closed Bug 1202973 Opened 4 years ago Closed 4 years ago

calllog: TypeError: can't redefine non-configurable property "TargetFactory"

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

defect
Not set

Tracking

(firefox43 fixed)

RESOLVED FIXED
Firefox 43
Tracking Status
firefox43 --- fixed

People

(Reporter: jryans, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

After bug 1196288, open desktop toolbox and get:

console.error:
  Failed to load module devtools/shared/gcli/commands/calllog: TypeError: can't redefine non-configurable property "TargetFactory"
console.error:
  DevToolsLoader.prototype.lazyRequireGetter@resource://gre/modules/devtools/shared/Loader.jsm:302:1
@resource://gre/modules/devtools/shared/gcli/commands/calllog.js:12:1
exports.createSystem/system.addItemsByModule/</options.loader@resource://gre/modules/devtools/gcli/system.js:165:20
exports.createSystem/loadModule@resource://gre/modules/devtools/gcli/system.js:112:30
exports.createSystem/system.load/promises<@resource://gre/modules/devtools/gcli/system.js:210:16
exports.createSystem/system.load@resource://gre/modules/devtools/gcli/system.js:208:22
GcliActor<._getRequisition@resource://gre/modules/devtools/server/actors/gcli.js:253:32
GcliActor<.specs<@resource://gre/modules/devtools/server/actors/gcli.js:96:12
actorProto/</handler@resource://gre/modules/devtools/server/protocol.js:1013:19
DSC_onPacket@resource://gre/modules/devtools/server/main.js:1591:15
ChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/devtools/shared/transport/transport.js:742:5
Looks you're defining TargetFactory twice.
Flags: needinfo?(poirot.alex)
Flags: needinfo?(poirot.alex)
Attachment #8658585 - Flags: review?(jwalker)
Attachment #8658585 - Flags: review?(jwalker) → review+
Duplicate of this bug: 1202980
https://hg.mozilla.org/mozilla-central/rev/c69a3e313517
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Duplicate of this bug: 1203902
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.