Closed Bug 1203053 Opened 5 years ago Closed 5 years ago

Search icon appears blank until turning on search suggestions

Categories

(Firefox for Android :: Awesomescreen, defect)

43 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 43
Tracking Status
firefox43 --- verified
fennec 43+ ---

People

(Reporter: TeoVermesan, Assigned: ally)

References

Details

Attachments

(2 files)

Tested with:
Device: Sony Xperia(Android 5.1)
Build: Firefox for Android  43.0a1 (2015-09-08)

Steps to reproduce:
1. Tap on URL Bar and type anything

Expected results:
- Just after the first word is typed, the Search Suggestion opt-in prompt is displayed: "Would you like to turn on search suggestions? [Yes] [No]"
- Below, the word typed at step 1 is displayed with the default search engine favicon

Actual result:
- The word typed at step 1 is displayed with a blank favicon

Note:
- after turning on "Search Suggestion", the favicon is displayed
- reproducible with all search engines
 for google, yahoo, wikipedia, bing).
tracking-fennec: --- → ?
Assignee: nobody → ally
tracking-fennec: ? → 43+
the pre-existing code relies on search suggestions from the engine arriving first (even if we don't show them) to behave correctly. 

I introduced a check on the suggestions enabled pref that short circuits if the pref has not been set and that is the root of this issue. I'll have a patch up later today.
Since you're already reviewing Bug 1202583, and this is a similar cause.
Attachment #8660059 - Flags: review?(mark.finkle)
Comment on attachment 8660059 [details] [diff] [review]
MissingSearchIcon

LGTM
Attachment #8660059 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/integration/fx-team/rev/00693818cbf5fdd073dd4d895be44771091e9432
Bug 1203053 - Search icon appears blank until turning on search suggestions.r=mfinkle
https://hg.mozilla.org/mozilla-central/rev/00693818cbf5
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Blocks: 1189719
Search icon is not displayed blank anymore in BrowserSearch screen, so:
Verified fixed using:
Device: LG G4 (Android 5.1)
Build: Firefox for Android 43.0a2 (2015-09-22)
You need to log in before you can comment on or make changes to this bug.