[Spark] - Failure in test_rocketbar_add_collection_save_bookmark.py in homescreen.tap_collection

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: manel, Assigned: manel)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150718201514

Steps to reproduce:

I have Flame contains Spark Build.
While I am working on bug 1188926, I run test_rocketbar_add_collection_save_bookmark.py test and I got always the same failure: https://pastebin.mozilla.org/8845704
I did this prints before the wait : print(self.apps.displayed_app.name) and print(self.name). The first print gave me Music and the second one Smart Collection
(Assignee)

Updated

2 years ago
Blocks: 1181535
I just tested this myself on Aries and it doesn't fail for me there, so I guess this is a failure specific to running Spark on the Flame.
She also showed me a screenshot of where the Music app was running, which is something that should never happen while this test is running.
No longer blocks: 1181535
Summary: [Aries] - Failure in test_rocketbar_add_collection_save_bookmark.py in homescreen.tap_collection → [Spark] - Failure in test_rocketbar_add_collection_save_bookmark.py in homescreen.tap_collection
Failure output of https://pastebin.mozilla.org/8845704 (from comment 0):
TEST-UNEXPECTED-ERROR | test_rocketbar_add_collection_save_bookmark.py TestRocketBarAddCollectionSaveBookmark.test_rocketbar_add_collection | TimeoutException: TimeoutException: Timed out after 30.1 seconds
 
 
Traceback (most recent call last):
  File "/home/mermi/FoxOS/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/home/mermi/FoxOS/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/rocketbar/test_rocketbar_add_collection_save_bookmark.py", line 33, in test_rocketbar_add_collection
    collection = homescreen.tap_collection(collection)
  File "/home/mermi/FoxOS/gaia/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/app.py", line 132, in tap_collection
    return Collection(self.marionette)
  File "/home/mermi/FoxOS/gaia/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/collections.py", line 24, in __init__
    Wait(self.marionette).until(lambda m: self.apps.displayed_app.name == self.name)
  File "/home/mermi/FoxOS/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 115086ms
 
SUMMARY
-------
passed: 0
Created attachment 8658645 [details]
2015-09-09-11-11-41.png

Looking at the screenshot she provided of the homescreen, it looks like the Music collection is installed.
When I look at the tap_collection method, it's just basically looking through all the apps on the homescreen and then taps on the first one that is called 'Music'. And since there is already an app named 'Music', that one is launched, instead of the Smart Collection Music app thing.
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/app.py#125
For me, when I run the test on Aries, "Entertainment" smart collection is installed on the Homescreen, and then the IMDB app is installed.
For Manel, it's the "Music" smart collection.
So apparently for her, the second choice in the select dialog of Smart Collections is "Music".
Created attachment 8658649 [details]
2015-09-09-12-12-49.png

This is a screenhost of Manel's smart collections dialog after Music smart collection is already installed.
There are far less choices than I see in there.

Comment 6

2 years ago
Created attachment 8658690 [details] [review]
[gaia] mermi:bug1203070 > mozilla-b2g:master
(Assignee)

Comment 7

2 years ago
Created attachment 8658693 [details] [review]
collection icon

I added a locator for the collections icon to be able to distinguish between the other icons, that's work in my side please need your review
Attachment #8658693 - Flags: review?(martijn.martijn)
Attachment #8658693 - Flags: review?(jlorenzo)

Updated

2 years ago
Assignee: nobody → manel.rhaiem92
Comment on attachment 8658693 [details] [review]
collection icon

Looks good to me, thanks!
Attachment #8658693 - Flags: review?(martijn.martijn) → review+
Comment on attachment 8658693 [details] [review]
collection icon

This small patch is great!

After thinking about it again, I think you were the only one to get that issue, because you're in a country where we have a few smart collections defined. In fact, the smart collections provided depend on the the country your IP is.
Attachment #8658693 - Flags: review?(jlorenzo) → review+
Landed in master at https://github.com/mozilla-b2g/gaia/commit/d740ed7ce5a4aa744ccceefd967e77b01203ab64
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.