Closed Bug 1203109 Opened 6 years ago Closed 6 years ago

Low res painted when scrolling medium.com on a retina display

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1144534

People

(Reporter: ehsan, Unassigned)

References

()

Details

(Whiteboard: [gfx-noted])

STR: Go to <https://medium.com/@InertialLemon/why-apple-will-switch-the-mac-to-arm-6e0a1f04c776> and scroll a bit.  Sometimes when the scroll is finished, we switch to low-res painting for a few moments and then we switch back to high-res painting.  Hovering on the links on that page also sometimes creates the same effect.
I don't have a retina mac so I can't repro but if this is actual low-res painting (and not something like bug 1144534) then we need to track it down and fix it.
How can I tell the difference between the two?
Actually low-res painting shouldn't even be enabled on desktop. The layers.low-precision-buffer pref is false except on B2G/Fennec, so unless you have it enabled locally you're probably seeing some variant of bug 1144534.

That being said, low-res painting is more "blurry" whereas if you take a look at the screenshot at e.g. https://bug1106592.bmoattachments.org/attachment.cgi?id=8546142 you'll see that is more of a "vertical stretch" kind of effect. I admit it's not easy to tell them apart. :( One thing that helps on B2G at least is that the low-res painting also has an opacity of 0.5 so it's more obvious. You can control that using the layers.low-precision-opacity pref.
Whiteboard: [gfx-noted]
Given bug 1203971 also reported the same thing on medium.com on B2G, I'm pretty sure this is the same issue. Duping to the master bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: fuzzy-text
You need to log in before you can comment on or make changes to this bug.