e10s - removing <select> element doesn't close the popup

RESOLVED DUPLICATE of bug 1253486

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1253486
3 years ago
2 years ago

People

(Reporter: enndeakin, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8658716 [details]
Testcase

If the <select> element is removed from the document, the popup does not close. Similarly, the page can be closed by a script, yet the popup will remain.
(Reporter)

Comment 1

3 years ago
Steps:

1. Click the button then quickly open the popup.

The popup should close when the <select> button disappears.
tracking-e10s: --- → +
Hi,

I have managed to reproduce this on Windows 10, Windows 7, Ubuntu 14.04 and Mac OS X 10.7 on the latest Aurora (46.0a2) only with e10s enabled.

Build ID    20160207004019
User Agent  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:46.0) Gecko/20100101 Firefox/46.0

Thanks,
Cipri

Updated

3 years ago
Priority: -- → P2
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253486
You need to log in before you can comment on or make changes to this bug.