Install tooltool packages for emulator builds

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: wcosta, Assigned: wcosta)

Tracking

Details

Attachments

(1 attachment)

We should run install-packages.sh for emulator builds as we do for b2g desktop.
Comment on attachment 8658781 [details] [diff] [review]
Add tooltool dependencies to emulator builds. r=garndt,dustin

https://tools.taskcluster.net/task-graph-inspector/#Gem1lePkSCav66cEEPDg9w/My-0gYPjQZqAYdMz-SvD3A/
Attachment #8658781 - Flags: review?(garndt)
Attachment #8658781 - Flags: review?(dustin)
Attachment #8658781 - Flags: feedback?(timdream)
Tim, could you please check the problems with gtk3 are gone?
Flags: needinfo?(timdream)
Thank you wcosta!

Here is my question:

LD_LIBRARY_PATH doesn't append the path of gtk3 in b2g-emulator-kk, see 

https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/MLfcrQRHQKu4n1bie42FIA/0/public/logs/live_backing.log

I think it should point to gtk3 like b2g-desktop-build:

https://bugzilla.mozilla.org/show_bug.cgi?id=1146713#c118

Is that ok to append gtk3 in LD_LIBRARY_PATH within this bug? thanks!
Flags: needinfo?(wcosta)
Comment on attachment 8658781 [details] [diff] [review]
Add tooltool dependencies to emulator builds. r=garndt,dustin

Review of attachment 8658781 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not terribly familiar with these scripts, but everything I can see here looks right :)
Attachment #8658781 - Flags: review?(dustin) → review+
(In reply to Ricky Chien [:rickychien] from comment #4)
> Thank you wcosta!
> 
> Here is my question:
> 
> LD_LIBRARY_PATH doesn't append the path of gtk3 in b2g-emulator-kk, see 
> 
> https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/
> MLfcrQRHQKu4n1bie42FIA/0/public/logs/live_backing.log
> 
> I think it should point to gtk3 like b2g-desktop-build:
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1146713#c118
> 
> Is that ok to append gtk3 in LD_LIBRARY_PATH within this bug? thanks!

Hi Tim,

It feels like this is more a emulator/gecko build issue than Taskcluster. Tracking down the desktop build, it adds [0], which sets up gtk. I don't the inner works of B2G build system to say how things should work for emulator builds.

[0] https://dxr.mozilla.org/mozilla-central/source/build/unix/mozconfig.gtk
Flags: needinfo?(wcosta)
Comment on attachment 8658781 [details] [diff] [review]
Add tooltool dependencies to emulator builds. r=garndt,dustin

Review of attachment 8658781 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8658781 - Flags: review?(garndt) → review+
(In reply to Wander Lairson Costa [:wcosta] from comment #6)
> (In reply to Ricky Chien [:rickychien] from comment #4)
> > Thank you wcosta!
> > 
> > Here is my question:
> > 
> > LD_LIBRARY_PATH doesn't append the path of gtk3 in b2g-emulator-kk, see 
> > 
> > https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/
> > MLfcrQRHQKu4n1bie42FIA/0/public/logs/live_backing.log
> > 
> > I think it should point to gtk3 like b2g-desktop-build:
> > 
> > https://bugzilla.mozilla.org/show_bug.cgi?id=1146713#c118
> > 
> > Is that ok to append gtk3 in LD_LIBRARY_PATH within this bug? thanks!
> 
> Hi Tim,
> 
> It feels like this is more a emulator/gecko build issue than Taskcluster.
> Tracking down the desktop build, it adds [0], which sets up gtk. I don't the
> inner works of B2G build system to say how things should work for emulator
> builds.

It's fine! I just don't know gtk3 path is set by taskcluster or b2g / gecko build.

Again, thanks for your help!
Comment on attachment 8658781 [details] [diff] [review]
Add tooltool dependencies to emulator builds. r=garndt,dustin

Per comment 8.
Flags: needinfo?(timdream)
Attachment #8658781 - Flags: feedback?(timdream) → feedback+
I guess we could check this in?
Keywords: checkin-needed
Blocks: 1203460
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/be57887bca91
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.