Will not print to a networked HP LaserJet 4000TN

VERIFIED DUPLICATE of bug 125144

Status

()

VERIFIED DUPLICATE of bug 125144
17 years ago
17 years ago

People

(Reporter: linuxrulez, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226
BuildID:    2001122617

When I want to print from the a web page I get this error on the HP LaserJet
4000TN printer:  40 EIO 2 Bad Transmission

When I try to print from Konqueror or Netscape 4.78 it will print my pages with
no errors.

I have checked the settings on the printer and my computer and they are correct
for printing to a network computer using TCP/IP.

Reproducible: Always
Steps to Reproduce:
1.File
2.Print
3.Print

or

1. CTRL
2. P
3. Print

Actual Results:  Printer would start blinking about a 40 EIO 2 Bad Transmission

Expected Results:  Been able to send the print job with no transmission errors.

Comment 1

17 years ago
I get this too.  Very frustrating.  We have four HP printers on JetDirect
queues.  Mozilla will print to two of them (both color LaserJet 4550DN's).  It
will not print to the B&W printers -- LasterJet 5M and LaserJet 4100N.  When
printing to both of these, I get the EIO transmission errors that the reporter
mentions.  This happens in both the browser and mail, build 2002020415.

If I save the file as .ps, and then print it, it will also fail to print.  It
looks like there is something wrong with the .ps file Mozilla is generating. 
Ghostview does display the .ps file OK.

In earlier builds of Mozilla, I believe that text pages printed OK, but any
pages with graphics did not.  I'm enclosing a testcase .ps file which
demonstrates the problem.

Comment 2

17 years ago
Created attachment 69572 [details]
.ps file which will not print on some HP printers

.ps file, generated from 'Print to File' of a small GIF image by 2002020415,
from http://www.astro.umd.edu/~hamilton/photos/slideshow/icons/RightArrow.gif .

Comment 3

17 years ago
Don/Boris, any ideas on this one?

Comment 4

17 years ago
Resolving as duplicate of bug 125144 where is a little more info.
Please add comment there about which Linux distributions are you seeing this with.

*** This bug has been marked as a duplicate of 125144 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
Red Hat Linux 7.2 was the operating system that I was using with that 
particular Mozilla build.  The kernel that was being used was 2.4.14.

Comment 6

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.