Add-on submission fails with a 400

RESOLVED FIXED

Status

Marketplace
Developer Pages
P1
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: krupa, Assigned: ngoke)

Tracking

Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
steps to reproduce:
1. Sign in and load https://marketplace-dev.allizom.org/content/addon/submit/
2. Upload a valid fxos add-on .zip file


expected behavior:
Add-on upload is successful

actual behavior:
Add-on upload fails with a 400

screenshot: https://www.dropbox.com/s/ya7oxyls8w2bjej/Screenshot%202015-09-09%2011.10.07.png?dl=0

POST /api/v2/extensions/extension/?_user=redacted&lang=en-US&region=restofworld HTTP/1.1
Host: marketplace-dev.allizom.org
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,ar;q=0.9,pt-BR;q=0.7,zh-CN;q=0.6,es;q=0.4,fr;q=0.3,en;q=0.1
Accept-Encoding: gzip, deflate
Content-Type: application/json; charset=UTF-8
Referer: https://marketplace-dev.allizom.org/content/addon/submit/
Content-Length: 45
Cookie: optimizelySegments=%7B%222000810488%22%3A%22false%22%2C%222017550344%22%3A%22ff%22%2C%221994990450%22%3A%22none%22%2C%222011280991%22%3A%22referral%22%7D; optimizelyEndUserId=oeu1412615683185r0.13675780769802803; optimizelyBuckets=%7B%7D; _ga=GA1.2.1091945615.1413320843; __utma=117863061.1091945615.1413320843.1441385025.1441389066.20; __utmz=117863061.1438606541.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); has_logged_in=1; __utmv=117863061.|14=Selected%20App%20Types=free-firefoxos=1; lang="en-US\054"; sessionid="redacted"
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache

HTTP/1.1 400 BAD REQUEST
access-control-allow-headers: X-HTTP-Method-Override, Content-Type
Access-Control-Allow-Methods: GET, PATCH, PUT, POST, DELETE, OPTIONS
Access-Control-Allow-Origin: *
access-control-expose-headers: API-Filter, API-Status, API-Version
Allow: GET, POST, HEAD, OPTIONS
API-Filter: carrier=&lang=en-US&pro=&region=restofworld
API-Pinned: True
API-Version: 2
content-security-policy-report-only: script-src https://*.newrelic.com https://marketplace-dev-cdn.allizom.org https://*.google-analytics.com 'self'; object-src 'none'; report-uri /services/csp/report
Content-Type: application/json
Date: Wed, 09 Sep 2015 17:54:06 GMT
Etag: "5de541580767dbc18906453fe57aa0b2"
Server: nginx
Strict-Transport-Security: max-age=31536000
Vary: API-Filter, Accept-Language, Cookie
X-Content-Type-Options: nosniff
Content-Length: 40
Connection: keep-alive
Thank you :ngoke
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
I lied. This is still failing with a 400.
Status: RESOLVED → REOPENED
Priority: -- → P1
Resolution: FIXED → ---

Updated

3 years ago
Assignee: nobody → kngo
(Assignee)

Comment 3

3 years ago
What ZIP file are you using? It works for me. Maybe this bug is outdated?
(Reporter)

Comment 4

3 years ago
Created attachment 8661489 [details]
simple-addon-statusbar-0.1.zip
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.