can't load local mail messages

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: spam, Assigned: sspitzer)

Tracking

({smoketest})

Trunk
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Starting mailnews on a fresh cvs build, linux, 20020116, i can't read mails.
The list displays, but clicking them displays nothing in message-pane.
Source and standalone msg windows are also blank.
News seem to be OK and can be read.

I don't know whether the warnings are related to the blank pane, but when
starting mailnews i get these warnings/errors in js console:

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

(repeated 3 more times)

Error: redeclaration of const hide
Source File: chrome://wallet/content/walletOverlay.js
Line: 1

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

(repeated 11 more times)

---

Double-clicking on a message spawns an empty message window and these errors:

Warning: anonymous function does not always return a value
Source File: chrome://messenger/content/messageWindow.js
Line: 559, Column: 1
Source Code:
	},

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

(repeated 2 more times)

Error: popup has no properties
Source File: chrome://editor/content/editorApplicationOverlay.js
Line: 77
(Reporter)

Comment 1

17 years ago
linux trunk 2002011606: no mails display there either. Warnings when starting
mailnews are:

Warning: function BeginDragFolderOutliner does not always return a value
Source File: chrome://messenger/content/messengerdnd.js
Line: 358, Column: 18
Source Code:
      return false;

Warning: function BeginDragFolderOutliner does not always return a value
Source File: chrome://messenger/content/messengerdnd.js
Line: 365, Column: 18
Source Code:
      return false;

Warning: function BeginDragFolderOutliner does not always return a value
Source File: chrome://messenger/content/messengerdnd.js
Line: 369, Column: 100
Source Code:
    return BeginDragOutliner(event, folderOutliner, selectedFolders,
"text/x-moz-message-or-folder");

Warning: function PromptSendMessages does not always return a value
Source File: chrome://messenger/content/mail-offline.js
Line: 140
Source Code:
}

Warning: function PromptDownloadMessages does not always return a value
Source File: chrome://messenger/content/mail-offline.js
Line: 186
Source Code:
}

Warning: function MailCheckBeforeOfflineChange does not always return a value
Source File: chrome://messenger/content/mail-offline.js
Line: 271
Source Code:
}

Warning: function PromptGetMessagesOffline does not always return a value
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1359
Source Code:
}

Warning: function PromptSendMessagesOffline does not always return a value
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1379
Source Code:
}

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

(repeated 3 more times)

Error: redeclaration of const hide
Source File: chrome://wallet/content/walletOverlay.js
Line: 1

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

(repeated 11 more times)
Severity: critical → blocker
I see this for POP mail accounts on commercial builds:

windows 2002-01-16-06-trunk
linux 2002-01-16-06-trunk
mac 2002-01-16-03-trunk

can not read messages in a POP account
IMAP accounts work fine.
Keywords: smoketest
OS: Linux → All
Hardware: PC → All
News messages aren't displayed either in latest CVS, same bug or a different one?
(Reporter)

Comment 4

17 years ago
news: likely related. I checked some old messages and could read them.
Looking further into it i have problems with some new messages. (and clicking to
clear out expired messages is also misbehaving again: clears current browser
content..)

Comment 5

17 years ago
building now.. will take a look. 

Comment 6

17 years ago
The JS errors posted in this bug are a red herring to the user's inability to
read messages. I'm using a build from the 11th of January and I have the exact
same errors (about the timline service not being defined and the
walletOverlay.js error). when opening a stand alone I also get the editor popup
undefined error. 

So I doubt any of those are causing messages not get displayed.

Comment 7

17 years ago
My debug buid on windows from last night(some time around 9:00) is fine. I see 
the same js errors and warnings.

Comment 8

17 years ago
The build I downloaded this morning has this problem.  I don't see any js errors
when I click on a local message.  (I see all of these errors before starting to
read mail).  But, no local message will display.
Priority: -- → P1
Target Milestone: --- → mozilla0.9.8
I've got a build from late last night, I'll investigate as well.
Status: NEW → ASSIGNED
js errors might not be related.

nsMailboxProtocol::SetupMessageExtraction() is failing to get the msgHdr from 
the running url.

when I load a local message, I get this assertion (followed by other assertions)

NTDLL! 77f9f9df()
nsDebug::Assertion(const char * 0x05671f34, const char * 0x05671f28, const char 
* 0x05671ee8, int 416) line 290 + 13 bytes
nsMailboxProtocol::SetupMessageExtraction() line 416 + 35 bytes
nsMailboxProtocol::Initialize(nsIURI * 0x05419614) line 193 + 8 bytes
nsMailboxService::NewChannel(nsMailboxService * const 0x057c561c, nsIURI * 
0x05419614, nsIChannel * * 0x0012ad80) line 495 + 12 bytes
nsIOService::NewChannelFromURI(nsIOService * const 0x00508aa0, nsIURI * 
0x05419614, nsIChannel * * 0x0012ad80) line 845 + 31 bytes
NS_OpenURI(nsIChannel * * 0x0012ae50, nsIURI * 0x05419614, nsIIOService * 
0x00508aa0, nsILoadGroup * 0x05370b80, nsIInterfaceRequestor * 0x041d8eb8, 
unsigned int 0) line 148 + 20 bytes
nsDocShell::DoURILoad(nsIURI * 0x05419614, nsIURI * 0x00000000, nsISupports * 
0x05732d10, nsIInputStream * 0x00000000, nsIInputStream * 0x00000000) line 4246 
+ 89 bytes
nsDocShell::InternalLoad(nsDocShell * const 0x041d8e90, nsIURI * 0x05419614, 
nsIURI * 0x00000000, nsISupports * 0x00000000, int 1, const unsigned short * 
0x00000000, nsIInputStream * 0x00000000, nsIInputStream * 0x00000000, unsigned 
int 1, nsISHEntry * 0x00000000) line 4149 + 39 bytes
nsDocShell::LoadURI(nsDocShell * const 0x041d8e90, nsIURI * 0x05419614, 
nsIDocShellLoadInfo * 0x00000000, unsigned int 0) line 584 + 65 bytes
nsMailboxService::FetchMessage(const char * 0x05419720, nsISupports * 
0x041d8fc4, nsIMsgWindow * 0x0548df10, nsIUrlListener * 0x00000000, const char 
* 0x00000000, int 1, const unsigned short * 0x00000000, nsIURI * * 0x00000000) 
line 218 + 43 bytes
nsMailboxService::DisplayMessage(nsMailboxService * const 0x057c5614, const 
char * 0x05419720, nsISupports * 0x041d8fc4, nsIMsgWindow * 0x0548df10, 
nsIUrlListener * 0x00000000, const unsigned short * 0x00000000, nsIURI * * 
0x00000000) line 252
nsMessenger::OpenURL(nsMessenger * const 0x0548a0d0, const char * 0x05419720) 
line 543
nsMsgDBView::LoadMessageByMsgKey(nsMsgDBView * const 0x053fae00, unsigned int 
10035884) line 880
nsMsgDBView::SelectionChanged(nsMsgDBView * const 0x053fae08) line 920
XPTC_InvokeByIndex(nsISupports * 0x053fae08, unsigned int 24, unsigned int 0, 
nsXPTCVariant * 0x0012b4e8) line 106
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode 
CALL_METHOD) line 1998 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x03fdc740, JSObject * 0x032b7fb8, unsigned int 
0, long * 0x04ec2f08, long * 0x0012b7c8) line 1266 + 14 bytes
js_Invoke(JSContext * 0x03fdc740, unsigned int 0, unsigned int 0) line 832 + 23 
bytes
js_Interpret(JSContext * 0x03fdc740, long * 0x0012c5b8) line 2798 + 15 bytes
js_Invoke(JSContext * 0x03fdc740, unsigned int 1, unsigned int 2) line 849 + 13 
bytes
js_InternalInvoke(JSContext * 0x03fdc740, JSObject * 0x03403488, long 54346920, 
unsigned int 0, unsigned int 1, long * 0x0012c828, long * 0x0012c6e0) line 924 
+ 20 bytes
JS_CallFunctionValue(JSContext * 0x03fdc740, JSObject * 0x03403488, long 
54346920, unsigned int 1, long * 0x0012c828, long * 0x0012c6e0) line 3405 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x03fdb160, void * 
0x03403488, void * 0x033d44a8, unsigned int 1, void * 0x0012c828, int * 
0x0012c82c, int 0) line 1011 + 33 bytes
nsJSEventListener::HandleEvent(nsJSEventListener * const 0x0527e4e0, 
nsIDOMEvent * 0x054199a8) line 180 + 77 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x0527e440, 
nsIDOMEvent * 0x054199a8, nsIDOMEventTarget * 0x04b0cc58, unsigned int 8, 
unsigned int 7) line 1205 + 20 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x04b0cba0, 
nsIPresContext * 0x04728b70, nsEvent * 0x0012d288, nsIDOMEvent * * 0x0012d208, 
nsIDOMEventTarget * 0x04b0cc58, unsigned int 7, nsEventStatus * 0x0012d2b0) 
line 1806 + 36 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x04b0cc50, nsIPresContext * 
0x04728b70, nsEvent * 0x0012d288, nsIDOMEvent * * 0x0012d208, unsigned int 1, 
nsEventStatus * 0x0012d2b0) line 3359
nsOutlinerSelection::FireOnSelectHandler() line 745
nsOutlinerSelection::Select(nsOutlinerSelection * const 0x05422e50, int 0) line 
373
XPTC_InvokeByIndex(nsISupports * 0x05422e50, unsigned int 7, unsigned int 1, 
nsXPTCVariant * 0x0012d484) line 106
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode 
CALL_METHOD) line 1998 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x03fdc740, JSObject * 0x0181fee8, unsigned int 
1, long * 0x04ec2ed0, long * 0x0012d764) line 1266 + 14 bytes
js_Invoke(JSContext * 0x03fdc740, unsigned int 1, unsigned int 0) line 832 + 23 
bytes
js_Interpret(JSContext * 0x03fdc740, long * 0x0012e554) line 2798 + 15 bytes
js_Invoke(JSContext * 0x03fdc740, unsigned int 1, unsigned int 2) line 849 + 13 
bytes
js_InternalInvoke(JSContext * 0x03fdc740, JSObject * 0x03403638, long 54349336, 
unsigned int 0, unsigned int 1, long * 0x0012e7c4, long * 0x0012e67c) line 924 
+ 20 bytes
JS_CallFunctionValue(JSContext * 0x03fdc740, JSObject * 0x03403638, long 
54349336, unsigned int 1, long * 0x0012e7c4, long * 0x0012e67c) line 3405 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x03fdb160, void * 
0x03403638, void * 0x033d4e18, unsigned int 1, void * 0x0012e7c4, int * 
0x0012e7c8, int 0) line 1011 + 33 bytes
nsJSEventListener::HandleEvent(nsJSEventListener * const 0x0541cc30, 
nsIDOMEvent * 0x0541bbe8) line 180 + 77 bytes
nsXBLPrototypeHandler::ExecuteHandler(nsXBLPrototypeHandler * const 0x041a5dc0, 
nsIDOMEventReceiver * 0x04ad28e8, nsIDOMEvent * 0x0541bbe8) line 442
DoMouse(nsIAtom * 0x028b0e80, nsIXBLPrototypeHandler * 0x041a5dc0, nsIDOMEvent 
* 0x0541bbe8, nsIDOMEventReceiver * 0x04ad28e8) line 118
nsXBLMouseHandler::MouseDown(nsXBLMouseHandler * const 0x0535eac0, nsIDOMEvent 
* 0x0541bbe8) line 123 + 40 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x0527e380, 
nsIPresContext * 0x04728b70, nsEvent * 0x0012f930, nsIDOMEvent * * 0x0012f618, 
nsIDOMEventTarget * 0x04ad28e8, unsigned int 7, nsEventStatus * 0x0012f828) 
line 1294 + 41 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x04ad28e0, nsIPresContext * 
0x04728b70, nsEvent * 0x0012f930, nsIDOMEvent * * 0x0012f618, unsigned int 1, 
nsEventStatus * 0x0012f828) line 3359
PresShell::HandleEventInternal(nsEvent * 0x0012f930, nsIView * 0x0535e550, 
unsigned int 1, nsEventStatus * 0x0012f828) line 5992 + 38 bytes
PresShell::HandleEvent(PresShell * const 0x04729914, nsIView * 0x0535e550, 
nsGUIEvent * 0x0012f930, nsEventStatus * 0x0012f828, int 0, int & 1) line 5909 
+ 25 bytes
nsView::HandleEvent(nsView * const 0x0535e550, nsGUIEvent * 0x0012f930, 
unsigned int 0, nsEventStatus * 0x0012f828, int 0, int & 1) line 387
nsView::HandleEvent(nsView * const 0x04728080, nsGUIEvent * 0x0012f930, 
unsigned int 0, nsEventStatus * 0x0012f828, int 1, int & 1) line 344
nsViewManager::DispatchEvent(nsViewManager * const 0x04728220, nsGUIEvent * 
0x0012f930, nsEventStatus * 0x0012f828) line 1909
HandleEvent(nsGUIEvent * 0x0012f930) line 83
nsWindow::DispatchEvent(nsWindow * const 0x0535e424, nsGUIEvent * 0x0012f930, 
nsEventStatus & nsEventStatus_eIgnore) line 850 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f930) line 871
nsWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000) line 4527 
+ 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000) line 
4779
nsWindow::ProcessMessage(unsigned int 513, unsigned int 1, long 524462, long * 
0x0012fd24) line 3414 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0002032a, unsigned int 513, unsigned int 1, 
long 524462) line 1115 + 27 bytes
USER32! 77e13eb0()
USER32! 77e1401a()
USER32! 77e192da()
nsAppShellService::Run(nsAppShellService * const 0x004b4ec0) line 303
main1(int 1, char * * 0x00444ba0, nsISupports * 0x00000000) line 1265 + 32 bytes
main(int 1, char * * 0x00444ba0) line 1605 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 
the URI seems bad: mailbox-message://sspitzer@mail.meer.net/Inbox#10035884

that key seems way high to me.

Comment 12

17 years ago
119051 looks mighty suspicious...i'd back that out and see what happens. 

Comment 13

17 years ago
Using 2001-01-16-06-trunk and 2001-01-16-09-trunk builds on Windows NT to read
mails, no problem to me.  No warnings/errors in js console neither.

Comment 14

17 years ago
It could be timeless checkin to mailboxUrl.cpp. 
Priority: P1 → --
Target Milestone: mozilla0.9.8 → ---
maybe that URI is ok, but on the mailbox url, m_messageKey is bad.

m_messageKey = 4294967295 (msgKey_None)

the call to rv = ioService->GetQueryAttributeValue(searchPart, "number", 

is failing

in ::ParseSearchPart()
        char * messageKey = nsnull;
        rv = ioService->GetQueryAttributeValue(searchPart, "number", 
&messageKey);
        ioService->GetQueryAttributeValue(searchPart, "messageid", 
&m_messageID);
        if (NS_SUCCEEDED(rv)) {
            m_messageKey = atol(messageKey); // convert to a long...
            PR_FREEIF(messageKey);
        }
I agree #119051 is very likely

it looks like the code is expecting us to pass in

"?number=12321"

when we pass in "number=12321" we fail.
Summary: js errors and warnings when starting mailnews - can't read mail → can't load local mail messages
the problem is this:

GetQuery() return "foo=bar"

but the call to GetQueryAttributeValue() expects "?foo=bar"

I say back timeless out.
I'm backing timeless out.  as soon as I verify that after backing him out 
everything works fine, I'll mark this fixed.
fixed.  backed timeless out.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
QA Contact: esther → sheelar
(Reporter)

Comment 20

17 years ago
*** Bug 120419 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
This bug also seems to have prevented some pages from displaying in a browser
window. I tried reading a file:// page from my local machine, and it was blank
also. Reverting to the 1/15 build fixed these
verified fixed on commercial builds:

windows 2002-01-17-06-trunk
linux 2002-01-17-06-trunk
mac 2002-01-17-06-trunk
Status: RESOLVED → VERIFIED
(Reporter)

Comment 23

17 years ago
*** Bug 120322 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.