All users were logged out of Bugzilla on October 13th, 2018

[Homescreen][Bookmark] Adding Bookmark to Homescreen will change small home screen Icons to large.

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: jthomas, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8658922 [details]
logcat_20150909_1406.txt

Description:
If the user has the bottom row icons on their Homescreen set to small, adding a Bookmark to Homescreen will drop the Bookmark in the last row (instead of creating a new row) and will make the last row from small icons to large icons.

Repro Steps:
1) Update a Aries to 20150909131315
2) Select Browser
3) Navigate to a link of your choice.
4) Select "..." in the top right of the browser.
5) Select Add link to home screen.

Actual:
Small Icons from the bottom row of Homescreen are changed to large icons.

Expected:
It is expected that the last row that was previously set to small icons will remain as small icons with the new book mark link being visible in a new row.

Environmental Variables:
Device: Aries 2.5 Kk
Build ID: 20150909131315
Gaia: 60e212543329ee48f2921e0cd92aaca4b4ce2f6a
Gecko: dd9e40b4695909f1595814c0e79e4d55d73dc283
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 4/4
See attached: Logcat & Video
Video link: https://youtu.be/sblTPnEDehI
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the Flame 2.5 and 2.2.
Result: Small icons from the bottom of the Homescreen become large. Bookmark link is added into the last row, so a new row is not created.

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
Build ID: 20150908193024
Gaia: e69f2c86b931b723dd405115e33a1d02e6c5f5e6
Gecko: 01ae99b53561a2c3b40533d8c1c92bd3efc42d00
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
Build ID: 20150908063003
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 96170c571381
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark]

Comment 2

3 years ago
Pretty sure that behaviour was by design, explicitly - newly installed apps and bookmarks always go into the last group, and it gets expanded if it's collapsed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.