Closed Bug 1203360 Opened 7 years ago Closed 7 years ago

crash in java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.onSearch(BrowserApp.java)

Categories

(Firefox for Android Graveyard :: General, defect)

43 Branch
ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1202583

People

(Reporter: kats, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-42aa799b-1fae-41f9-809b-9c6fb2150910.
=============================================================

Seems to be 100% reproducible on nightly - i type something in the url bar and hit the "search suggestion" button right underneath. My default search engine is set to mxr.m.o
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202583
Kats - Out of curiosity and completely off topic, why do you tap that button? It is exactly what you typed. You could just press 'Go' on the keyboard.

Reason I ask is that we are considering removal of that button.
Flags: needinfo?(bugmail.mozilla)
I guess it's mostly habit but also partly because that button is less ambiguous - I know it will do a search rather than possibly trying to load it as a URL. I would much rather use the search engine icons at the bottom of the screen if bug 1051544 ever gets fixed, because then I wouldn't have to bother remembering what I have set as my default search engine (I sometimes forget whether I have bugzilla or mxr as my default) and it would be even less "ambiguous".
Flags: needinfo?(bugmail.mozilla)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.