Closed Bug 1203443 Opened 6 years ago Closed 6 years ago

[Dialer]Receive a call from a contact with a phone number but no contact name, the first number of this phone number is shown as contact name.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: yulan.zhu, Assigned: gsvelto)

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-2])

Attachments

(4 files)

[1.Description]:
[AreisKK v2.5&FlameKK v2.5][Dialer]Receive a call from a contact with a phone number but no contact name, the first number of this phone number is shown as contact name.
See attachment:AriesKK_v2.5_video.3gp and AriesKK_v2.5_logcat.txt.
Occurrence time:10:05

[2.Testing Steps]: 
1.Create a contact with no contact name.  
2.Receive a call from this contact with a phone number but no contact name.


[3.Expected Result]: 
2.The phone number should be shown in dialing view.

[4.Actual Result]: 
2.The first number of the phone number is shown as contact name.

[5.Reproduction build]: 
Device: AreisKK v2.5 build (Affected)
Build ID               20150909215153
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.211310
Firmware Date          Wed Sep  9 21:13:17 UTC 2015
Bootloader             s1

Device: FlameKK v2.5 build (Affected)
Build ID               20150909150223
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.185733
Firmware Date          Wed Sep  9 18:57:43 EDT 2015
Bootloader             L1TC000118D0

Device:FlameKK v2.2 build (Unaffected)
Build ID               20150909032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/96170c571381
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.065103
Firmware Date          Wed Sep  9 06:51:14 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
2253

[8.Note]:
Call the contact with a number but no contact name, the same issue will occur.
Attached video AriesKK_v2.5_video.3gp
The base image version of FlameKK is v18D v4.
[Blocking Requested - why for this release]: Visual regression from 2.2.
blocking-b2g: --- → 2.5?
Comms triage: Visual regression on the dialer
blocking-b2g: 2.5? → 2.5+
Priority: -- → P3
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150731154437
Gaia Revision          a83366dc9f73182bb43d06b22337670aa5d71cb6
Gaia Date              2015-07-31 22:04:40
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/1e51e74f2de7
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150802.183402
Firmware Date          Sun Aug  2 18:34:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150731163337
Gaia Revision          1a814a4e7fa57132cdc0512a6c363b6b9471431d
Gaia Date              2015-07-31 23:07:21
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/afd2a51ce670
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150802.183402
Firmware Date          Sun Aug  2 18:34:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro 
Gaia Revision          1a814a4e7fa57132cdc0512a6c363b6b9471431d
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/1e51e74f2de7

First Broken Gecko & Last Working Gaia - issue DOES NOT repro 
Gaia Revision          a83366dc9f73182bb43d06b22337670aa5d71cb6
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/afd2a51ce670

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/a83366dc9f73182bb43d06b22337670aa5d71cb6...1a814a4e7fa57132cdc0512a6c363b6b9471431d
Hi Gabriele,
This bug is probably caused by Bug 1104667, could you help to check?  
Thank you.
Flags: needinfo?(gsvelto)
QA Whiteboard: [MGSEI-Triage+]
Yes, I've figured out what the problem is. Previously |Utils.getPhoneNumberPrimaryInfo()| would return either an array of names (the mozContact.name field) or a string (the number). This worked correctly because we set this value directly in the textContent property of the number information node so, if we had only a string (say 456) we'd get:

456

If we'd have an array with a single name (Foo) we'd get:

Foo

And finally if we had multiple elements ([Foo, Bar]) we'd automatically get them concatenated with commas in-between:

Foo,Bar

Now we're only taking the first element, which works for a name but not for a number in which we take only the first digit. I'll post a patch ASAP.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
Comment on attachment 8661688 [details] [review]
[gaia] gabrielesvelto:bug-1203443-fix-contact-without-name > mozilla-b2g:master

This was a really trivial fix. In the case where get |Utils.getPhoneNumberPrimaryInfo()| returns a number (which is a string) we pass it over to l10n as a raw string, this obviously works. In the case where we have a contact name we receive an array of names and we can still just hand it over to l10n as it will be turned into a raw string holding all the array elements with appropriate separators (e.g. a comma for the US-en local). This happens when the l10n code stores it in the |textContent| field of the element. BTW this treatment of the |textContent| field is the reason why only one unit-test needed to be changed.
Attachment #8661688 - Flags: review?(thills)
Comment on attachment 8661688 [details] [review]
[gaia] gabrielesvelto:bug-1203443-fix-contact-without-name > mozilla-b2g:master

Hi Gabriele,

It looks good to me.  I did a little testing as well.

Thank you,

-tamara
Attachment #8661688 - Flags: review?(thills) → review+
Thanks for the review, merged into gaia/master 187a8e94f9edba20fc6260d66883ed82a8aef647

https://github.com/mozilla-b2g/gaia/commit/187a8e94f9edba20fc6260d66883ed82a8aef647
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This issue is verified as pass on latest FlameKK&AriesKK v2.5 build by the same STR in comment 0.
Actual Result:The phone number is shown as name in dialing view.
Reproducing rate:0/10
See attachment:Verify1_AriesKK_v2.5.3gp

Device: FlameKK v2.5 build (Pass)
Build ID               20150923150203
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4a46de29431baa621d98d8f1168e43297ce1a916
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150923.184655
Firmware Date          Wed Sep 23 18:47:17 EDT 2015
Base Image             v18D v4
Bootloader             L1TC000118D0

Device:AriesKK v2.5 build (Pass)
Build ID               20150923233246
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f1dffc8682fbba463cb4bb305f293ddcccbc20b4
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.225204
Firmware Date          Wed Sep 23 22:52:12 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.