Editing Chinese Canvas tutorial page fails

RESOLVED FIXED

Status

developer.mozilla.org
Wiki pages
P5
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ende93, Assigned: groovecoder)

Tracking

({in-triage})

Details

(URL)

(Reporter)

Description

3 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

error happened when i wanted to edited this page, and the link of the page failed too.
Status: UNCONFIRMED → NEW
Component: General → Wiki pages
Ever confirmed: true
Product: Developer Documentation → Mozilla Developer Network
Summary: cant find edit page → Editing Chinese Canvas tutorial page fails
It's a 404. Assigning this as major until we know whether it's isolated or sitewide.
Severity: normal → major
Keywords: in-triage
(Assignee)

Comment 2

3 years ago
It's localized to this page, having lost its relationship to its English "parent" somehow. :( It's topical parent - https://developer.mozilla.org/zh-CN/docs/Web/API/Canvas_API$edit - can be edited.
Severity: major → normal
(Assignee)

Updated

3 years ago
Assignee: nobody → lcrouch
(Assignee)

Comment 3

3 years ago
This page's parent has been deleted:

https://developer-local.allizom.org/en-US/docs/Trash/Canvas_tutorial-broken

:fscholz - looks like there are a number of translations of that deleted document that need to have their translation parents set to the new page?

ende93@hotmail.com - how did you navigate to this document?
Flags: needinfo?(fscholz)
Flags: needinfo?(ende93)
(Reporter)

Comment 4

3 years ago
(In reply to Luke Crouch [:groovecoder] from comment #3)
> This page's parent has been deleted:
> 
> https://developer-local.allizom.org/en-US/docs/Trash/Canvas_tutorial-broken
> 
> :fscholz - looks like there are a number of translations of that deleted
> document that need to have their translation parents set to the new page?
> 
> ende93@hotmail.com - how did you navigate to this document?

I just clicked "Canvas 教程" of  https://developer.mozilla.org/zh-CN/docs/Web/API/Canvas_API page
Flags: needinfo?(ende93)
(Assignee)

Comment 5

3 years ago
That makes sense.

+ :teoli - can you fix this page by setting its parent document to be the new doc that has replaced the deleted doc? (Can use the "View in Admin" link to get to https://developer.mozilla.org/admin/wiki/document/55147/)

If that works, it's our work-around for docs like this in the future.
Flags: needinfo?(jypenator)
Forwarding the ni/ to Florian as I'm in PTO for the rest of the week
Flags: needinfo?(jypenator)
(In reply to Luke Crouch [:groovecoder] from comment #5)
> That makes sense.
> 
> + :teoli - can you fix this page by setting its parent document to be the
> new doc that has replaced the deleted doc? (Can use the "View in Admin" link
> to get to https://developer.mozilla.org/admin/wiki/document/55147/)
> 
> If that works, it's our work-around for docs like this in the future.

This worked and the page is editable again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(fscholz)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.