Closed Bug 1203500 Opened 4 years ago Closed 4 years ago

IMG with srcset wrapped in TABLE set incorrect TD with

Categories

(Core :: Layout: Tables, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1149357

People

(Reporter: el92, Unassigned)

Details

Attachments

(1 file)

Attached image srset-bug.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

1. Open http://el-shadow.github.io/srcset/
2. Zoom page by ⌘+ (Ctrl + ) to change devicePixelRatio greater of 1
3. Refresh page and see TABLE TD witdh


Actual results:

Page contain IMG tag with 
srcset="
assets/srcset_@x.png 1x,
assets/srcset_@2x.png 2x,
assets/srcset_@3x.png 3x"

img width 1x = 326px 

When loaded x2 asset, table td get size twice as much


Expected results:

Table TD should get size of content. (asset width of 1x image in any devicePixelRatio)
Component: Untriaged → Layout: Tables
Product: Firefox → Core
Thank you for the bug report!  This is a general problem with shrink-wrapping widths for ancestors of srcset images...
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149357
You need to log in before you can comment on or make changes to this bug.