local-part of address is incorrectly quoted if it contains an exclamation mark

RESOLVED DUPLICATE of bug 1213748

Status

RESOLVED DUPLICATE of bug 1213748
3 years ago
3 years ago

People

(Reporter: andreas.mahling, Unassigned)

Tracking

x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150827140610

Steps to reproduce:

entered an address like !mygroup@example.com 


Actual results:

TB quotes local-part to "!mygroup"@example.com causing the mail to bounce.

From my point of view, this behavoiur does not conform to rfc 2822 3.4.1, as atext characters may contain exclamation marks and the local-part therefore should not be quoted

 


Expected results:

leave local-part as is
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Untriaged → MIME
Product: Thunderbird → MailNews Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213748
You need to log in before you can comment on or make changes to this bug.