[dashboard] Redesign dashboards

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mathjazz, Assigned: mathjazz)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 affected)

Details

(Assignee)

Description

3 years ago
As we add more information to these dashboards, we will eventually need to make them wider. Currently they look like they support monitors from the 80s. I think we can safely make them e.g. 960px wide and thus require monitors from the 90s. :-) Responsive design would be even better.

Also, since projects/locales/resources mostly don't fit into a single screen height, we could use multiple lines per project/locale/resource and bigger fonts.
(Assignee)

Updated

3 years ago
Summary: Redesign dashboards → [dashboard] Redesign
(Assignee)

Comment 1

3 years ago
Dashboard titles and subtitles could also use less space.

There should be a clear distinction between main navigation (on top), the newly added 2nd-level navigation (tabs) and other options (like contributor period).

They pages themselves could also look prettier.
Summary: [dashboard] Redesign → [dashboard] Redesign dashboards
(Assignee)

Updated

3 years ago
Depends on: 1200188, 1207615, 1214847
(Assignee)

Updated

3 years ago
Priority: -- → P3
(Assignee)

Comment 2

3 years ago
We might also want to show top contributor of each project/locale on the overview page. And on contributors pages, we could dispaly information like "#2 contributor for this locale and/or project".

We should figure out if there should also be a request a project option on team pages, similarly to request a locale option on project pages.
(Assignee)

Comment 3

3 years ago
Locale managers should also be listed a long with the option for authenticated users to request (translator) permission from them.

Updated

3 years ago
Depends on: 1228038
(Assignee)

Comment 4

3 years ago
One should be able to sign in/out from the dashboard.
(Assignee)

Comment 5

3 years ago
Things like number of enabled/complete locales for project or enabled/complete projects for locale are also valuable.
(Assignee)

Updated

3 years ago
Depends on: 1229854
(Assignee)

Comment 6

3 years ago
Locale and project-locale dashboard should have quick links:
- translate N missing strings
- review N suggestions
Priority: P3 → P2
(Assignee)

Comment 7

3 years ago
All resources link must be added to project-locale dashboard (blocked by bug 1243086).
Depends on: 1243086
(Assignee)

Comment 8

3 years ago
We should also allow file download/upload.

And include deadline and priority information.
(Assignee)

Updated

3 years ago
Assignee: nobody → m
(Assignee)

Comment 9

2 years ago
In project dashboard, there should be a link to the repository.
I would like to see a Project Info page. Some of this already exists.  This page contains the following, though not limited to, and may or may not be applicable to all projects, and should be configurable:
- Project/Product owner (customer)
- Dev
- Project/product summary
- L10n PM
- production URL
- staging URL
- github URL
- release cycle, deadline, or if one time only, when it ends (such as campaign)
- locale options: required; optional (can community request to participate); open to anyone
- a link to the dashboard of locale translation progress
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1323738
(Assignee)

Updated

2 years ago
Depends on: 1333884

Comment 12

2 years ago
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/6f8f51e9b9c0dda03c6b014f8be60da197424848
Fix bug 1203543: Redesign dashboards (#544)

This is huge. The initial idea was to simply add the ability to track
deadlines and prioritize projects. It turned out we needed to redesign
dashboards to fit new columns, so I revived my old work on
[bug 1203543](https://bugzilla.mozilla.org/show_bug.cgi?id=1203543),
which took care of that.

Here's a short summary of the changes:

**1. The `pontoon.base` app has been split into several (5) new apps:**
* `pontoon.teams`
* `pontoon.projects`
* `pontoon.localizations` (i.e. project-locales)
* `pontoon.machinery` (previously referred to as Terminology in the UI)
* `pontoon.contributors`

I moved URL patterns, views, templates and static files to new apps.
I also refactored some of the macros, widgets and includes to better
suit changes described in the following two items.

The `pontoon.base` app is still around and contains reusable resources,
models, translate view (should be our next target to spin off as spearate
app) and the terms page. Hopefully, the code will now be easier to read
and maintain.

**2. Redesigned dashboards.**
Additional information can now be assigned to projects:
* _deadline_ (styled differently if overdue or approaching)
* _priority level_ (1 to 5 stars)
* _public repository website_ (e.g. https://github.com/mozilla/pontoon-intro/)

Team (locale) dashboards also include new information:
* _writing direction_ (left-to-right or right-to-left)
* _script_ (e.g. latin)
* _number of literate speakers_ (taken from CLDR)
* _bugs_ (bugzilla query shamelessly stolen from elmo)

More information is available on the localization dashboard:
* Contributors
* Project info
* Team info

Latest activity column shows more information about the latest
translation in the tooltip.

Project, Team, and Localization dashboards have received the biggest changes:
* Navigation between their subpages (e.g. between Slovenian projects and
  contributors) is now AJAX-based and as such - faster. Links and history
  should still work as expected. Pages loaded via AJAX live in the
  `includes` folder within their corresponding app.
* Together with Teams, Projects and Top Contributors pages, they
  introduce a richer heading with more information about teams, projects,
  top contributor, project, team, localization and the current stats.
* They contain direct links to translate page for each item in their
  listing of teams, projects or resources. Hover the item and under the
  horizontal progress bar you will notice links for each of the status
  filters.

**3. New header.**
* Header on top of each page has been simplified with less frequent
  actions moved to the menu on the right hand side.
* It contains a placeholder for notifications, which now slide down
  from the top of the page.
* For non-authenticated users, we show a hamburger menu instead of the
  'Anonymous' title with the Red Panda avatar.
* There's also a slim YouTube-like horizontal progress bar on top of the
  header, which shows up on AJAX requests, e.g. as you navigate between
  project dasboard subpages.
* Since header is included almost everywhere, the majority of pages have
  been slightly redesigned to match the new design (color scheme, heading
  style, form widgets).

**4. Other changes.**
* The default page width has been increased to 980px (from 735px).
* We use comma as thousands separator when presenting stats.
* The repository section in the project admin has been redesigned.
* Prefetch latest activity data to reduce number of DB queries and page
  load time on dashboards.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.