Crash (Seg Fault) when switching themes from modern to classic and back at slashdot.

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Greg, Assigned: Joe Hewitt (gone))

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using the 2002011608 build on linux:

Start on the "Modern" theme

1. Go to http://slashdot.org
2. Switch to "Classic" theme
3. Switch back to "Modern"

Crash.

Comment 1

17 years ago
Dupe of bug 117386?
Severity: major → critical
Keywords: crash

Comment 2

17 years ago
... or of bug 115919?

Comment 3

17 years ago
WFM on Linux 2002011608; yesterday's build crashes. Since  bug 117386 has been
fixed in the meantime this seems it; mark fixed ?

(Reporter)

Comment 4

17 years ago
The problem still occurs in 2002011708 (there was some mention of a theme fix on
mozillazine.org for Jan 16).

It also spits this out:

/home/magnesium/tmp/mozilla/run-mozilla.sh: line 72:  2102 Segmentation fault  
   $prog ${1+"$@"}
(Reporter)

Comment 5

17 years ago
On build 2002012705, this issue is still present.  Talkback build ID TB2177089W.

--Greg
stephend, could you get the stack?  TB2177089W.

0x0876a365
nsStyleContext::Destroy()
nsStyleContext::Release()
nsStyleContext::~nsStyleContext()
nsStyleContext::Destroy()
nsStyleContext::Release()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ComputeStyleChangeFor()
PresShell::ReconstructStyleData()
PresShell::StyleSheetRemoved()
nsDocument::UpdateStyleSheets()
nsChromeRegistry::RefreshWindow()
nsChromeRegistry::RefreshWindow()
nsChromeRegistry::RefreshSkins()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsEventListenerManager::HandleEventSubType()
nsEventListenerManager::HandleEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
PresShell::HandleDOMEventWithTarget()
nsMenuFrame::Execute()
nsMenuFrame::HandleEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::DispatchMouseEvent()
nsWidget::OnButtonReleaseSignal()
nsWindow::HandleGDKEvent()
dispatch_superwin_event()
handle_gdk_event()
libgdk-1.2.so.0 + 0x17477 (0x4034b477)
libglib-1.2.so.0 + 0x10578 (0x4037b578)
libglib-1.2.so.0 + 0x10b83 (0x4037bb83)
libglib-1.2.so.0 + 0x10d1c (0x4037bd1c)
libgtk-1.2.so.0 + 0x8d7f7 (0x4029c7f7)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1d6cf (0x404bf6cf) 
Looks like bug 116038 to me....
Component: Themes → Style System

Comment 9

17 years ago
Trigger Reason  SIGSEGV: Segmentation Fault: (signal 11)
User Comments Start on the "Modern" theme 1. Go to http://slashdot.org 2. Switch
to "Classic" theme 3. Switch back to "Modern" Crash.
Stack Trace
0x0876a365
nsStyleContext::Destroy()
nsStyleContext::Release()
nsStyleContext::~nsStyleContext()
nsStyleContext::Destroy()
nsStyleContext::Release()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ReResolveStyleContext()
FrameManager::ComputeStyleChangeFor()
PresShell::ReconstructStyleData()
PresShell::StyleSheetRemoved()
nsDocument::UpdateStyleSheets()
nsChromeRegistry::RefreshWindow()
nsChromeRegistry::RefreshWindow()
nsChromeRegistry::RefreshSkins()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsEventListenerManager::HandleEventSubType()
nsEventListenerManager::HandleEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
PresShell::HandleDOMEventWithTarget()
nsMenuFrame::Execute()
nsMenuFrame::HandleEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::DispatchMouseEvent()
nsWidget::OnButtonReleaseSignal()
nsWindow::HandleGDKEvent()
dispatch_superwin_event()
handle_gdk_event()
libgdk-1.2.so.0 + 0x17477 (0x4034b477)
libglib-1.2.so.0 + 0x10578 (0x4037b578)
libglib-1.2.so.0 + 0x10b83 (0x4037bb83)
libglib-1.2.so.0 + 0x10d1c (0x4037bd1c)
libgtk-1.2.so.0 + 0x8d7f7 (0x4029c7f7)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1d6cf (0x404bf6cf) 
Component: Style System → Themes

Comment 10

17 years ago
I'm using Mozilla 0.9.8+ (build 2002021413) on a fully patched Red Hat 7.2/i386,
and it appears to work just fine without crashing. Maybe the bug was fixed.

Comment 11

17 years ago
CONFIRM on Linux Mandrake 8.0 gcc 2.95.3 glib-2.2.2 gtk-1.2.10, But for me the
thing only appears when doing exactly the following:

1. Start Mozilla with the Modern Theme Selected
2. Switch to Classic
3. Switch back to Modern -> Crash

This happened with build Feb 23th 2002.

GDB Output attached

Comment 12

17 years ago
Created attachment 71084 [details]
GDB Output

GDB Output Build Feb 23th, Swtiched from Modern -> Classic -> Modern
(Reporter)

Comment 13

16 years ago
seems to have been fixed - worksforme now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.