Closed Bug 1203554 Opened 4 years ago Closed 4 years ago

9% linux svg opacity regression on Aurora (v.42) seen September 4th from revision 4fa21e75f4ee

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox42 - wontfix

People

(Reporter: jmaher, Unassigned, NeedInfo)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

a compare view to show the problem:
https://treeherder.allizom.org/perf.html#/compare?originalProject=mozilla-aurora&originalRevision=5a18731300d8&newProject=mozilla-aurora&newRevision=4fa21e75f4ee

this is specifically in the tsvgr_opacity big-optimizable-group-opacity-2500.svg test:
https://treeherder.allizom.org/perf.html#/comparesubtest?originalProject=mozilla-aurora&originalRevision=5a18731300d8&newProject=mozilla-aurora&newRevision=4fa21e75f4ee&originalSignature=b98a5a90dfcf07eb3d784ca1cd4ade4de6e6c44a&newSignature=b98a5a90dfcf07eb3d784ca1cd4ade4de6e6c44a


this is a big combination push:
https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?changeset=4fa21e75f4ee

we have documented the alerts with links to graphs/treeherder here:
http://alertmanager.allizom.org:8080/alerts.html?rev=4fa21e75f4ee&showAll=1&testIndex=0&platIndex=0

this looks specific to aurora, as we don't see this on inbound.  I have done a series of try pushes (yes, this will take a while to get pgo builds completed):
https://treeherder.mozilla.org/#/jobs?repo=try&author=jmaher@mozilla.com&fromchange=7675ece875c5&tochange=6e5e5ec37f15

Ideally we will be able to determine which is the root cause and then put this bug in the right product/component and cc the right folks to get action.

We get alerts much later on aurora due to the lower volume, so that is why this is 1 week delayed.
Summary: 9% linux svg regression on Aurora (v.42) seen September 4th from revision 4fa21e75f4ee → 9% linux svg opacity regression on Aurora (v.42) seen September 4th from revision 4fa21e75f4ee
this appears to be:
https://hg.mozilla.org/releases/mozilla-aurora/rev/272572ec32e4

this is where we went from values posting < 255 and all of these are >260, most are >270.

the compare view shows this:
https://treeherder.allizom.org/perf.html#/compare?originalProject=try&originalRevision=329700a1d941&newProject=try&newRevision=6e5e5ec37f15

I am not sure why this is only showing on aurora, but this is a large regression that seems to reproduce with try pushes.

:dao, can you take a look at this?
Blocks: 1185960
Component: Talos → Theme
Flags: needinfo?(dao)
Product: Testing → Firefox
Really weird that this is limited to both aurora and linux. Maybe there were some linux-specifc graphics changes making linear-gradient on mozilla-central less expensive than on aurora?
Flags: needinfo?(dao)
[Tracking Requested - why for this release]: Sylvestre, I thought you might like to be aware of this for 42.
Seth, do you know why the perf impact of this change would be higher on aurora than on central, and if there's something we can do about this (or do you have suggestions about who would) ?
Flags: needinfo?(seth)
Wontfix since this appears to be limited to Linux and Firefox 42.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Looks like we won't be doing anything about this.
You need to log in before you can comment on or make changes to this bug.