contacts are empty and contacts settings won't open

RESOLVED DUPLICATE of bug 1202916

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1202916
3 years ago
3 years ago

People

(Reporter: ralf tauscher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [contacts])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826185640

Steps to reproduce:

open contacts app


Actual results:

it opened, but seems to be empty


Expected results:

my 300 contacts should be displayed
(Reporter)

Comment 1

3 years ago
I am on:
git show
commit 6280500a6cb8d1b178cdd163450e36d22846fbed

and adb logcat shows me this error:

E/Communications(29071): [JavaScript Error: "SyntaxError: JSON.parse: unexpected non-whitespace character after JSON data at line 1 column 173 of the JSON data" {file: "app://communications.gaiamobile.org/contacts/js/utilities/cookie.js" line: 48}]


inside cookie.js its this function:

  // Parses the cookie returning the corresponding object
  // Returns null if the cookie string does not conform with expected format
  function _parseCookie(cookie) {
    // Expecting "preferences=<JSON value>"
    var index = cookie.indexOf(COOKIE_NAME_EQ);
    if (index === -1) {
      return null;
    }
    var cookieVal = cookie.substring(index + COOKIE_NAME_LENGHT);
    if (!cookieVal) {
      return null;
    }

    return JSON.parse(decodeURIComponent(cookieVal));
  }
(Reporter)

Updated

3 years ago
Whiteboard: [contacts]
(Reporter)

Comment 2

3 years ago
it happend after updating gaia. seems to be a problem during migration. I built an older gaia commit but it didn't helped.

interesting so far: contacts is empty within "contacts app" and in dialer. but suggest search within messages is working. all contacts are still there and I'm able to select them from there. 

clicking on the "+" (going into contacts) is still empty.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202916
You need to log in before you can comment on or make changes to this bug.