Closed Bug 1203737 Opened 4 years ago Closed 4 years ago

crash in mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&)

Categories

(Core :: Audio/Video, defect, P2, critical)

defect

Tracking

()

RESOLVED FIXED
mozilla44
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: KTucker, Unassigned)

References

()

Details

(Keywords: crash, regression, reproducible, Whiteboard: [2.5-Daily-Testing][Spark])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-5f2606a8-cf08-47eb-bc13-fec312150910.
=============================================================

Repro Steps:
1) Update a Aries to 20150909215207
2) Open up the browser and go to m.youtube.com
3) Tap on the 3 dots by the search icon to open up the menu and tap on "Desktop". 
4) On the desktop version of "Youtube", look towards the top of the page and tap "switch to mobile". 
5) Tap on a video to play it and keep locking and unlocking the phone.

Actual:
Youtube will crash after unlocking the phone. 

Expected:
Youtube does not crash and video plays normally after unlocking the phone.

Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 1/10 attempts 10%
See attached: logcat, video
Component: Gaia::Browser → Audio/Video
Product: Firefox OS → Core
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage+]
Keywords: steps-wanted
Whiteboard: [2.5-Daily-Testing][Spark]
0 	libxul.so 	mozilla::BaseAutoLock<mozilla::Mutex>::BaseAutoLock(mozilla::Mutex&) 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/Mutex.h:69
1 	libxul.so 	void mozilla::MozPromise<nsTArray<mozilla::TrackInfo::TrackType>, mozilla::MediaDataDecoder::DecoderFailureReason, true>::Private::Reject<mozilla::MediaDataDecoder::DecoderFailureReason const&>(mozilla::MediaDataDecoder::DecoderFailureReason const&, char const*) 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/MozPromise.h:682
2 	libxul.so 	libxul.so@0xd7dc71 	
3 	libxul.so 	mozilla::EnableIf<mozilla::ReturnTypeIs<void (mozilla::EMEDecryptor::*)(mozilla::DecryptResult const&), void>::value&&mozilla::TakesArgument<void (mozilla::EMEDecryptor::*)(mozilla::DecryptResult const&)>::value, already_AddRefed<mozilla::MozPromise<mozilla::DecryptResult, mozilla::DecryptResult, true> > >::Type mozilla::MozPromise<mozilla::DecryptResult, mozilla::DecryptResult, true>::InvokeCallbackMethod<mozilla::EMEDecryptor, void (mozilla::EMEDecryptor::*)(mozilla::DecryptResult const&), mozilla::DecryptResult const&>(mozilla::EMEDecryptor*, void (mozilla::EMEDecryptor::*)(mozilla::DecryptResult const&), mozilla::DecryptResult const&) 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/MozPromise.h:431
4 	libxul.so 	mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::FunctionThenValue<mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::All(mozilla::AbstractThread*, nsTArray<nsRefPtr<mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true> > >&)::{lambda(mozilla::TrackInfo::TrackType)#1}, mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::All(mozilla::AbstractThread*, nsTArray<nsRefPtr<mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true> > >&)::{lambda(mozilla::MediaDataDecoder::DecoderFailureReason)#2}>::DoResolveOrRejectInternal(mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::ResolveOrRejectValue const&) 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/MozPromise.h:540
5 	libxul.so 	mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::ThenValueBase::DoResolveOrReject(mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::ResolveOrRejectValue const&) 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/MozPromise.h:381
6 	libxul.so 	mozilla::MozPromise<mozilla::TrackInfo::TrackType, mozilla::MediaDataDecoder::DecoderFailureReason, true>::ThenValueBase::ResolveOrRejectRunnable::Run() 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/MozPromise.h:314
7 	libxul.so 	mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run() 	/home/worker/workspace/B2G/objdir-gecko/dist/include/mozilla/TaskDispatcher.h:180
8 	libxul.so 	mozilla::TaskQueue::Runner::Run() 	xpcom/threads/TaskQueue.cpp
9 	libxul.so 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp
10 	libxul.so 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
11 	libxul.so 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
12 	libxul.so 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
13 	libxul.so 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
14 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
15 	libxul.so 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
16 	libnss3.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c
17 	libc.so 	__thread_entry 	/builds/slave/b2g_m-cen_flm-kk_ntly-00000000/build/bionic/libc/bionic/pthread_create.cpp:105
18 	libc.so 	pthread_create 	/builds/slave/b2g_m-cen_flm-kk_ntly-00000000/build/bionic/libc/bionic/pthread_create.cpp:224
19 		@0xad3902fe
I was unable to reproduce this issue on the same Aries build.  Leaving the tag so another tester can try to reproduce.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
I am also unable to reproduce this crash using the same build as the reporter. I attempted locking and unlocking the device multiple times using a number of videos, as well as having multiple youtube videos open in separate windows at the same time.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Leaving steps-wanted tag for another tester to attempt.
Flags: needinfo?(jmercado)
I attempted locking and unlocking while watching a youtube video for over an hour and not once did I encounter a crash. Removing steps-wanted due to inability to reproduce.

Device: Aries 2.5
BuildID: 20150915152315
Gaia: d2e5c49440bf8410ae747b15c0dd11c54053ef3e
Gecko: 112ed0121136e9e642e34382256ec73d33bb1b86
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Keywords: steps-wanted
Kevin have you seen this on more recent builds?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ktucker)
I attempted to reproduce on Aries and Nexus 5. The issue cannot be reproduced. Remove 2.5? flag. KT, please help to review this again. If issue doesn't exist, please close this bug. Thanks.

Build ID               20150921150203
Gaia Revision          29991414eb94b6baa1ec2e63fdb4f6dfae05fb01
Gaia Date              2015-09-21 09:27:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/197af2fb7e29ff8e4b3b6ced723b6172e954e17d
Gecko Version          44.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150610.034847
Firmware Date          Wed Jun 10 03:49:06 EDT 2015
Bootloader             HHZ12h

Build ID               20150921020825
Gaia Revision          e67d319d0854e32e23210784eb9c4e1b8a025adb
Gaia Date              2015-09-19 07:42:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d9724506c66754540416e8435ad3c1feabf29590
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150921.012407
Firmware Date          Mon Sep 21 01:24:15 UTC 2015
Bootloader             s1
blocking-b2g: 2.5? → ---
We can now reproduce this crash 100% of the time on the latest Aries 2.5

STR

1. Open the video app.
2. Tap on "Go to camera" when prompted that no videos are found on the device.  
2. Record five 10 sec long videos. 
3. Tap the home button after recording 5 videos and open up the "Video" app. 
4. Tap on a video to play it and then immediately epeatedly tap the rewind, fast forward, play/pause buttons and move the slider around until you kind of see the video go blank.
5. Tap on a another video to play it. (If you reproduced the bug,  you will be prompted that "another app is currently using the video player". 
6. Tap the home button to go to the homescreen and then reopen the video app.

Actual: A crash will occur.

Expected: No crash will occur. 

Please note that others are getting this crash randomly but this seems to be the best way to reproduce the crash. I pretty much can get it consistently now.
blocking-b2g: --- → 2.5?
Flags: needinfo?(ktucker)
I made several attempts but I could not reproduce this on Flame 2.5

The video app did not crash when performing the steps in Comment 8.

Device: Flame 2.5 (Full Flash)(KK)(319mb)
BuildID: 20150924030228
Gaia: 4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gecko: bf2bc1aa78c0b72d9b6b13f7a8c6ae61c60a51dc
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Summary: crash in mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&) → [Aries] crash in mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&)
QAwanted to confirm the steps at comment 8.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
I can confirm the steps at comment 8 reproduces the issue. The hard part is getting step 4 to occur. Once step 4 occurs the rest of the steps easily lead to a crash.

I was able to crash the device on Flame as well. Crash report on Flame:
https://crash-stats.mozilla.com/report/index/5f2b87c5-3d4d-4c6c-a733-d638c2150924

The above crash occurred on:
Device: Flame 2.5 (512MB memory)
BuildID: 20150924030228
Gaia: 4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gecko: bf2bc1aa78c0b72d9b6b13f7a8c6ae61c60a51dc
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

I can't seem to get the crash to occur on Flame 2.2. But it could be that I'm not trying hard enough for step 4 to occur.

Device: Flame 2.2 (512MB memory)
BuildID: 20150924032502
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 65ddad73ad6b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Summary: [Aries] crash in mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&) → crash in mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&)
I spent some more time trying to repro this on Flame 2.2 and ran into another crash:
https://crash-stats.mozilla.com/report/index/8af6e145-182d-486c-a4ba-4b5672150924

For now I'm marking 2.2 as unaffected. (same environmental variables as above)
Let's try getting a regression window here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
Attached file logs.txt
I got that issue today on the latest Aries 2.5 
https://crash-stats.mozilla.com/report/index/be81e6ce-4f3e-41eb-9c88-3fab22150925

STR:
1. Open Browser and navigate to http://nytimes.com
2. Scroll to the end of the page and tap on the "Video" link
3. Tap on any video and wait until it will start
4. Tap on any different video (You should see black screen, video won't start streaming)
5. Press "Home" button
6. Launch the Browser

Repro rate: 10/10
https://youtu.be/3LsKqI75-SE


Device: Aries Master
Build ID: 20150925134904
Gaia: 5a0a1bb1a863b07528ebc1a04652ed656d8333b3
Gecko: 543e1b3a25887258a70d1f2dab3cb287d0d500e4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
I can repro the crash on Aries using steps at comment 15, but the same steps can't seem to crash Flame 2.5 512MB. Comment 15 steps are MUCH easier to do than comment 8 steps, so I'll try the window on aries using comment 15 steps first.
FWIW, I have encountered this crash on desktop Linux with Firefox 43.0a2 (20150925), e10s enabled: bp-cbce4f68-a977-487e-b7b6-8aa232150926.

Looking at the crash stats, there seems to be quite a few crashes on desktop 43.0a1 and 44.0a1 as well.
I can consistently reproduce this by setting media.fragmented-mp4.exposed and media.fragmented-mp4.gmp.enabled to true (thus using GMP for MSE + H.264), then navigating to a YouTube video.

The FFmpeg backend is not affected.
Bleh. Finding another YouTube video that will trigger this seems to be harder than I thought. Here's one: https://www.youtube.com/watch?v=y9o0YZS_eGc
OS: Gonk (Firefox OS) → All
Hardware: ARM → All
(In reply to David [:auscompgeek] from comment #18)
> I can consistently reproduce this by setting media.fragmented-mp4.exposed
> and media.fragmented-mp4.gmp.enabled to true (thus using GMP for MSE +
> H.264), then navigating to a YouTube video.

Starting in the last 24 hours, I'm getting it on Desktop Linux all sorts of sites, but particularly Facebook, with these two prefs enabled. I'm using Aurora.

Gerv
(In reply to Gervase Markham [:gerv] from comment #20)
> Starting in the last 24 hours, I'm getting it on Desktop Linux all sorts of
> sites, but particularly Facebook, with these two prefs enabled. I'm using
> Aurora.

Indeed, I've been seeing this quite often whilst scrolling through Facebook myself.

This also happens in a non-e10s window, so e10s isn't the problem here.
Blocking for 2.5 as crash occurs. Priority P2 as STR are complex.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Here's a central regression window that I'm not sure if it's 100% correct, using steps at comment 15 (steps at comment 8 are too time consuming and results are unreliable so can't be used to find the window). When I proceeded into mozilla inbound, all the crashes that I had gotten have missing symbols hence can't determine if they're the same crash as this one. Even on latest mozilla inbound full flash I got missing symbol crashes.

I believe any more attempt in finding the window will be a waste of time as I've spent nearly 2 days working on this, so taking the tag off.

Last Working
Device: Aries 2.5
BuildID: 20150818175310
Gaia: 507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gecko: 2c272af993c23e803f6ea7798a812b0c8abfad4d
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Aries 2.5
BuildID: 20150818233403
Gaia: 507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gecko: db4616cd0721f40f0c9c794c67c95fbb7355f321
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working Gaia First Broken Gecko - repro
Gaia: 507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gecko: db4616cd0721f40f0c9c794c67c95fbb7355f321

Last Working Gecko First Broken Gaia - no repro
Gaia: 507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gecko: 2c272af993c23e803f6ea7798a812b0c8abfad4d

Gecko pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2c272af993c23e803f6ea7798a812b0c8abfad4d&tochange=db4616cd0721f40f0c9c794c67c95fbb7355f321
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
No-Jun, does this pushlog have anything that jumps out to you?  I'm not sure where to start with it.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(npark)
Hmm, my guess is as good as yours, but since it's a video decoder issue, following patches seem to stand out for me:

	88df6aa8bf02	Alfredo Yang — Bug 1195625 - Use correct TaskQueue in SharedDecoderManager and H264Converter promise. r=jya
	37c52f612c75	Alfredo Yang — Bug 1179667 - Use MozPromise to initialize Gonk PlatformDecodeModule. r=jya

Hi Alfredo, we have this critical failure, and was wondering whether your patch might be related to this?  thanks!
Flags: needinfo?(npark) → needinfo?(ayang)
It looks like bug 1207214.
Flags: needinfo?(ayang)
It looks ok after applying patch at bug 1204622. I'll double confirm it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204622
Alfredo: I saw this bug on desktop Linux, so it's unlikely to be a duplicate of a bug which is Firefox OS-specific. Has something gone wrong here?

Gerv
Flags: needinfo?(ayang)
(In reply to Gervase Markham [:gerv] from comment #29)
> Alfredo: I saw this bug on desktop Linux, so it's unlikely to be a duplicate
> of a bug which is Firefox OS-specific. Has something gone wrong here?
> 
> Gerv

The regression window in comment 25 is for Gonk only, it won't impact to other platforms.
Do you have similar reproduce steps as comment 8? I can check it on desktop.
Flags: needinfo?(ayang) → needinfo?(gerv)
I can reproduce this by enabling media.fragmented-mp4.gmp.enabled and trying to view a video, such as the one on https://www.theoplayer.com/documentation/hls.html#hls-features .

Here's a crash report: 
https://crash-stats.mozilla.com/report/index/0ad46ca8-19a7-4ec3-af91-760532151008
"Firefox 43.0a2 Crash Report [@ mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&) ]"

Gerv
Flags: needinfo?(gerv)
Feel free to move this discussion to another bug if you prefer.

Gerv
Flags: needinfo?(ayang)
(In reply to Gervase Markham [:gerv] from comment #31)
> I can reproduce this by enabling media.fragmented-mp4.gmp.enabled and trying
> to view a video, such as the one on
> https://www.theoplayer.com/documentation/hls.html#hls-features .
> 
> Here's a crash report: 
> https://crash-stats.mozilla.com/report/index/0ad46ca8-19a7-4ec3-af91-
> 760532151008
> "Firefox 43.0a2 Crash Report [@
> mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&) ]"
> 
> Gerv


I can't produce the same crash as comment 31 but found the video can't be played with a GMP error.


2015-10-16 07:09:59.168381 UTC - -1653568896[7f988e24d000]: SourceBuffer(7f987cff4ce0:video/mp4)::QueueAsyncSimpleEvent: Queuing event 'update'
2015-10-16 07:09:59.168391 UTC - -1653568896[7f988e24d000]: SourceBuffer(7f987cff4ce0:video/mp4)::QueueAsyncSimpleEvent: Queuing event 'updateend'
2015-10-16 07:09:59.168410 UTC - -1653568896[7f988e24d000]: SourceBuffer(7f987cff49c0:audio/mp4)::DispatchSimpleEvent: Dispatch event 'update'
2015-10-16 07:09:59.168411 UTC - 2019862272[7f98792b2b80]: MediaFormatReader(7f9871cb9c00)::NotifyDemuxer: aLength=1, aOffset=1
2015-10-16 07:09:59.168446 UTC - -1653568896[7f988e24d000]: SourceBuffer(7f987cff49c0:audio/mp4)::DispatchSimpleEvent: Dispatch event 'updateend'
2015-10-16 07:09:59.168766 UTC - -1653568896[7f988e24d000]: SourceBuffer(7f987cff4ce0:video/mp4)::DispatchSimpleEvent: Dispatch event 'update'
2015-10-16 07:09:59.168791 UTC - -1653568896[7f988e24d000]: SourceBuffer(7f987cff4ce0:video/mp4)::DispatchSimpleEvent: Dispatch event 'updateend'
IPDL protocol error: Handler for LoadGMP returned error code

###!!! [Parent][DispatchSyncMessage] Error: (msgtype=0x6E0001,name=PGMPService::Msg_LoadGMP) Processing error: message was deserialized, but the handler returned false (indicating failure)

2015-10-16 07:09:59.184170 UTC - 2020259584[7f98792b27c0]: MediaFormatReader(7f9871cb9c00)::NotifyError: Audio Decoding error
2015-10-16 07:09:59.184185 UTC - 2020259584[7f98792b27c0]: MediaFormatReader(7f9871cb9c00)::ScheduleUpdate: SchedulingUpdate(Audio)
2015-10-16 07:09:59.184192 UTC - 2020259584[7f98792b27c0]: MediaFormatReader(7f9871cb9c00)::NotifyError: Video Decoding error
2015-10-16 07:09:59.184197 UTC - 2020259584[7f98792b27c0]: MediaFormatReader(7f9871cb9c00)::ScheduleUpdate: SchedulingUpdate(Video)


Hi Jya, have you seen that before?
Flags: needinfo?(ayang) → needinfo?(jyavenard)
(In reply to Alfredo Yang (:alfredo) from comment #33)
> I can't produce the same crash as comment 31 but found the video can't be
> played with a GMP error.

is that on Aries ? can you reproduce this with a desktop build?

does playback start? what resolution did you use?

> 2015-10-16 07:09:59.184170 UTC - 2020259584[7f98792b27c0]:
> MediaFormatReader(7f9871cb9c00)::NotifyError: Audio Decoding error
> 2015-10-16 07:09:59.184185 UTC - 2020259584[7f98792b27c0]:
> MediaFormatReader(7f9871cb9c00)::ScheduleUpdate: SchedulingUpdate(Audio)
> 2015-10-16 07:09:59.184192 UTC - 2020259584[7f98792b27c0]:
> MediaFormatReader(7f9871cb9c00)::NotifyError: Video Decoding error
> 2015-10-16 07:09:59.184197 UTC - 2020259584[7f98792b27c0]:
> MediaFormatReader(7f9871cb9c00)::ScheduleUpdate: SchedulingUpdate(Video)
> 
> 
> Hi Jya, have you seen that before?

no, but this could happen if the GMP PDM is active (media.gmp.decoder.enabled set to true), and the Gonk PDM::SupportsMimeType returned false, and you have a GMP PDM installed that returned true; I'm not aware of any GMP that exists though.

Chris?
Flags: needinfo?(jyavenard) → needinfo?(cpearce)
(In reply to Jean-Yves Avenard [:jya] from comment #34)
> (In reply to Alfredo Yang (:alfredo) from comment #33)
> > I can't produce the same crash as comment 31 but found the video can't be
> > played with a GMP error.
> 
> is that on Aries ? can you reproduce this with a desktop build?
> 
> does playback start? what resolution did you use?

It is on desktop, the playback doesn't start. The test url is https://www.theoplayer.com/documentation/hls.html#hls-features.

The original of this bug is crash, https://crash-stats.mozilla.com/report/index/0ad46ca8-19a7-4ec3-af91-760532151008. I can't reproduce it but :gerv reproduced it at Firefox 43.0a2.

Reopen this bug because it is not a dup of bug 1204622.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
working fine here for me.
The crash in https://crash-stats.mozilla.com/report/index/5f2606a8-cf08-47eb-bc13-fec312150910 from comment 0 can only happen if a site is using EME.

Or perhaps the compiler has optimized an identical code path to use the same code that has EMEDecryptor's name. That happens on Windows all the time, I'm not sure if gcc/clang or whatever FirefoxOS builds with does that too.

AFAICT, no site listed here in the STR is using EME.

(In reply to Gervase Markham [:gerv] from comment #31)
> I can reproduce this by enabling media.fragmented-mp4.gmp.enabled and trying
> to view a video, such as the one on
> https://www.theoplayer.com/documentation/hls.html#hls-features .
> 
> Here's a crash report: 
> https://crash-stats.mozilla.com/report/index/0ad46ca8-19a7-4ec3-af91-
> 760532151008
> "Firefox 43.0a2 Crash Report [@
> mozilla::BaseAutoLock<T>::BaseAutoLock(mozilla::Mutex&) ]"
> 
> Gerv

Enabling media.fragmented-mp4.gmp.enabled/media.gmp.decoder.enabled causing trouble isn't really surprising; it is disabled for a reason! If you try current Nightly, do you see the crash there? There's been some changes that should help.
Flags: needinfo?(cpearce) → needinfo?(gerv)
(In reply to Chris Pearce (:cpearce) from comment #37)
> Enabling media.fragmented-mp4.gmp.enabled/media.gmp.decoder.enabled causing
> trouble isn't really surprising; it is disabled for a reason! If you try
> current Nightly, do you see the crash there? There's been some changes that
> should help.

Good news: with 44.0a1 (2015-10-20) on Linux x86_64, I can no longer reproduce the crash with either my YouTube video or gerv's link. Can still repro on Aurora.

Closing this bug. It would be great if gerv, or someone else, could verify my findings.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Flags: needinfo?(gerv)
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
(In reply to David [:auscompgeek] from comment #38)
> (In reply to Chris Pearce (:cpearce) from comment #37)
> > Enabling media.fragmented-mp4.gmp.enabled/media.gmp.decoder.enabled causing
> > trouble isn't really surprising; it is disabled for a reason! 

Sure. But does that also mean you don't want bug reports about it?

> Good news: with 44.0a1 (2015-10-20) on Linux x86_64, I can no longer
> reproduce the crash with either my YouTube video or gerv's link. Can still
> repro on Aurora.

I no longer get a crash with nightly on
https://www.theoplayer.com/documentation/hls.html#hls-features
with media.fragmented-mp4.gmp.enabled set to true, although the vid doesn't play either.

Gerv
You need to log in before you can comment on or make changes to this bug.