Closed Bug 1203762 Opened 4 years ago Closed 4 years ago

[Contacts] Images disappear when user enables and disables order by last button inside the contacts list.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: vbelonenko, Assigned: arcturus)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(4 files)

Description: The  order by last name button does not function property when user adds an image next to contacts.


Repro Steps:
1. launch contacts app
2. create a couple new contacts with pictures from gallery
3. change a contacts last name for example: aaaaa.
4. Select Setting click enable Order by Last name button
5. change  contacts last name again.
6. Disable Order by Last name button.
7. Observe that when contacts move from alphabetical order to non alphabetical order they lose images on the side.
 
Actual:
When user adds couple contacts with images than disables and enables button. Changes last names. Some contact images disappear.
 
Expected:
Pictures should not disappear when user clicks order by last name button.

Environmental Variables:
Device: Aries 2.5 kk Full Flash (319 mb)
Build ID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 3/3
See attached: Video and logcat
This issue  also occurs 2.5 Flame 
Result: Contacts Images disappear when user enables and disables order by last button inside the contacts 

Environmental Variables:
Device: Flame 2.5 kk Full Flash (319 mb)
Build ID: 20150909163019
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

-------------------------------------------------------------------------------------------

This issue still occurs on 2.2 Flame 
Result: Contacts Images disappear when user enables and disables order by last button inside the contacts 

Environmental Variables:
Device: Flame 2.2 kk Full Flash (319 mb)
Build ID: 20150909183023
Gaia: 7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gecko: 0d9c46d01861
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Johan, can you take a look at this?
Flags: needinfo?(ktucker) → needinfo?(jlorenzo)
[Blocking Requested - why for this release]: Functional regression from 2.1

I didn't reproduce the issue on 2.1 [1]. As the problem is also in 2.2, I'm suspecting that's a fallout of bug 1112551. I thought I tested this case back at that time, but if I read the messages I left in that bug, I don't see this case. Sorry, I missed it :s 

[1] Build ID               20150724001207
Gaia Revision          9dba58d18006e921546cec62c76074ce81e16518
Gaia Date              2015-07-23 12:36:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/41e10c6740be
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150724.035246
Firmware Date          Fri Jul 24 03:52:57 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.5?
Flags: needinfo?(jlorenzo)
Keywords: regression
I am also seeing this error and it's really confusing for the user. 

Just adding that after the bug is reproduced, if I kill Contacts app and launch it again the images appear again in the contact list.
blocking-b2g: 2.5? → 2.5+
Assignee: nobody → francisco
Status: NEW → ASSIGNED
This issue happens in both branches, master and NGA, so leaving 2.5+ blocking flag.
Comment on attachment 8663759 [details] [review]
[gaia] arcturus:bug-1203762 > mozilla-b2g:master

This has been a really tricky one.

We were missing the images cause we were revoking the image object url, since the visibility monitor was being reloaded, making it going twice through the list rendering and evicting the urls.

Happening just when we force a reload of the list from the settings panel, like changing the order.
Attachment #8663759 - Flags: review?(ferjmoreno)
Attachment #8663759 - Flags: review?(ferjmoreno) → review+
Unfortunately, I am still seeing the issue in latest master build 

Environmental Variables (9/24):
flame master (2.5 version)
Build ID: 20150924072151
Gecko: 65a0dd9
Gaia: 7e72976
Platform version: 44.0a1

Setting verifyme keyword so QA team can confirm it and, in case they also reproduce it, reopen the bug.
Keywords: verifyme
Yes this issue is still occurring. I don't even have to do all the steps, I can see the bug at step 4. But doing all the steps does still reproduce the bug. Re-opening bug per comment 9's request.

Bug still reproduces on (confirmed that the fix is included in gaia):
Device: Flame 2.5
BuildID: 20150924030228
Gaia: 4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gecko: bf2bc1aa78c0b72d9b6b13f7a8c6ae61c60a51dc
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Aries 2.5
BuildID: 20150924111215
Gaia: 4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gecko: 001942e4617b2324bfa6cdfb1155581cbc3f0cc4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: verifyme
Resolution: FIXED → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Managed to reproduce, but in a list with just 1 contact.

In a list where not all contacts are on the screen is not reproducible.
Duplicate of this bug: 1206280
Priority: -- → P2
This is tricker than expected, since the visibility monitor is triggering the rendering of a row several times.

That makes us invalidate the blob uri and therefore, we don't display anything.

Now we know the causes, but the fix seems not to be easy.
Comment on attachment 8674200 [details] [review]
[gaia] arcturus:bug-1203762-2 > mozilla-b2g:master

Hi Fernando, here it comes the second part.

It was easier than expected once I decided to solve it without involving the visibility monitor.

Now when we render, we check that if we have an image and that image is same that we are trying to reload, we dont do it, doing this operation just when we are reusing an element.
Attachment #8674200 - Flags: review?(ferjmoreno)
Attachment #8674200 - Flags: review?(ferjmoreno) → review+
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/14cd2d07e4390f9ebf5736d7b59ed9b33fd63b9f

... and nga branch:

https://github.com/mozilla-b2g/gaia/commit/32e87b66d58c2859ef0d2d3e8bc1295132564f0d
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
I cannot see this bug when there are only one or two contacts created. 
Aries 2.5
BuildID: 20151018190150
Gaia: f75a7e01

But, when the contact list has many contacts, scrolling down to see one of the contact's info and then scrolling up again it is possible to see how the first contact's picture is not shown. Please see video attached, look at contacts Aaa B1 and Aaaa A2. But seems a different bug, do not you thinks so? If so, I will file a new one. Thanks
Attached image VID_0002.jpg
Flags: needinfo?(francisco)
Sorry I did not filed the video but a screenshot. Here you can see the current behavior I mentioned: 

https://youtu.be/tOFn2LSkoUs 

Pay attention to the two first contacts and how the picture of the first one disappears after changing the order and then scrolling.
If the app is closed and open, then the picture is loaded.
Filed a new bug for previous comment #19, bug 1216477. The image disappears when scrolling no matter if the 'order by' toggle is changed.
Thanks Isabel, will investigate the new bug opened.
Flags: needinfo?(francisco)
You need to log in before you can comment on or make changes to this bug.