Closed Bug 1203850 Opened 4 years ago Closed 4 years ago

Rename srcVideoObject and related variables/attributes to clarify they are about the media stream, not just the video

Categories

(Hello (Loop) :: Client, defect, P3)

defect
Points:
2

Tracking

(firefox43 fixed)

RESOLVED FIXED
mozilla43
Iteration:
43.3 - Sep 21
Tracking Status
firefox43 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Split out from review comments on bug 1203529:

::: browser/components/loop/content/shared/js/actions.js
@@ +232,5 @@
> +     */
> +    MediaStreamCreated: Action.define("mediaStreamCreated", {
> +      hasVideo: Boolean,
> +      isLocal: Boolean,
> +      srcVideoObject: Object

Global rename this to srcStreamObject for readability?
This does various block replacements for the *VideoObject -> *StreamObject. The tests still pass. I used sublimes search & replace in files facility.
Attachment #8659791 - Flags: review?(dmose)
Comment on attachment 8659791 [details] [diff] [review]
Rename Loop's srcVideoObject and related variables/attributes to clarify they are about the media stream, not just the video.

Review of attachment 8659791 [details] [diff] [review]:
-----------------------------------------------------------------

rs=dmose.  However, it has occurred to me that an even clearer name would be srcMediaElement, since this is actually what's being passed, (ie it's not the stream itself, and it's an HTML MediaElement, not some random JS object).  so rs=dmose if you want to switch to that before landing.
Attachment #8659791 - Flags: review?(dmose) → review+
Updated to srcMediaElement etc, I agree that makes sense.
https://hg.mozilla.org/mozilla-central/rev/085137ec0ab2
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.