Closed Bug 1203854 Opened 4 years ago Closed 4 years ago

drag and drop of address to other address book fails

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

SeaMonkey 2.35 Branch
Unspecified
Windows 7
defect
Not set

Tracking

(seamonkey2.38 affected, seamonkey2.40 unaffected)

RESOLVED DUPLICATE of bug 1202553
Tracking Status
seamonkey2.38 --- affected
seamonkey2.40 --- unaffected

People

(Reporter: anthony1947, Unassigned)

Details

(Keywords: regression, Whiteboard: this is NOT resolved. This was CTL suggestion is useless and was mentioned for several years. I already tried it before sending in the bug report.....something in 2.35 and the 2.38b1 beta version has corrupted the code for drag and drop in address book. …)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 SeaMonkey/2.35
Build ID: 20150827182544

Steps to reproduce:

I researched this and there were issues with this as far back as 2009.  I got the new version 2.35 and could no longer drag and drop a name from my PAB to lists within the PAB that I have.  I then upgraded to Beta 2.38 and same thing....then I loaded up 2.25 and and 2.31 and I was able to drag and drop.  I then went back to 2.35 and the new Beta 2.38 and again was not able to drag and drop names....I checked Thunderbird and was able to drag and drop there....  So something is definitely wrong with 2.35 and beta 2.38


Actual results:

see above.....  I don't know how much clearer I can be about this.  It will no longer allow me to drag names from the PAB that shows on the right hand box to any address book or any sub list within any address book showing on the left.  I could do this yesterday but not today due to whatever is wrong in 2.35 and 2.38....but any EARLIER version of SeaMonkey once reinstalled allows drag and drop functionality within the Address Book management area.


Expected results:

I should have been able to drag and drop names to populate my address lists within my PAB.  I could only populate the sublists now by opening the sub list and start typing a name and then it found the name and I was able to do it manually..  So it can be done re amending the lists but not with drag and drop any longer.   So it is clear that 2.35 and 2.38 have a bug in it since earlier versions do not and this was the very first time in years of use of SeaMonkey and earlier of course in Netscape.....and currently in Thunderbird.  The google searches I saw from previous years were simply out of control in terms of trying to explain what was going on some years ago when this took place and got mired down in back and forth rhetoric of genius people trying to make end users look like total idiots.   This is a very, very simple to explain problem.  The fact earlier versions of SeaMonkey allowed me once again to drag and drop names into lists means there is definitely something wrong in 2.35 and 2.38...  But for security reasons, it is risky I guess to use earlier and now unsupported versions of SeaMonkey.  I hope this explanation is very clear and I hope I am not assaulted by people wanting this to be made into a more complex issue than I described.  Drag and Drop in the Address Book worked until ver 2.35.  It is as simple as that though the bug that created this problem may not be so simple to fix.   I  have seen references to something like this in the records section here and claims it was "fixed" but I don't think so and maybe this is a variant.  I use WIN7 64 BIT HOME edition.  Never had this problem before and again earlier versions of SEAMONKEY do not create this error where you try and drag and drop and all you get is a black circle with a line through it.
to be very exact..... I used ver 2.25  and ver 2.32.1  and could drag and drop.........then i used 2.35 and Beta version
2.38b1 and was unable to drag and drop....sorry for not getting the exact version down re 2.32.1 ..i had to look in the download tool and find it...sorry.
Steps how to with  German SeaMonkey 2.38b1  (Windows NT 6.1; WOW64; rv:41.0)  Gecko/20100101 Firefox/41.0 Build 20150904215228  (Classic Theme) on German WIN7 64bit:

1. Open address book
2. Click first address in personal address book
3. <control> + left mouse button, drag and drop to arbitrary other
   address book
   Expected: Mouse pointer view changes from "forbidden" to square with "+"
             in it, drag and drop successful
   Actual:  Mouse pointer view stays "forbidden", drag and drop fails.

a) No DUPs found in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1203854&sharer_id=41036&list_id=12540804>
b) Works fine with TB 43.0a1 (2015-09-08)
c) Already REPRODUCIBLE with DE SeaMonkey 2.35(γ)  (Windows NT 6.1; Win64; x64;
   rv:38.0 nightly by Adrian Kalla)  Gecko/20100101 Build 20150615204754 
   (Classic Theme) on German WIN7 64bit
d) Worked fine with EN-US SeaMonkey 2.33.1 (German Language pack)  
   Gecko/20100101 Build 20150321194901 (Classic Theme) on German WIN7 64bit

@reporter:
Please concentrate on essential facts related to observed bug due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
Status: UNCONFIRMED → NEW
Component: General → MailNews: Address Book & Contacts
Ever confirmed: true
Keywords: regression
OS: Unspecified → Windows 7
Summary: drag and drop in address book stopped working in 2.35 and beta 2.38 → drag and drop of address to other address book fails
e) Works fine  with  German SeaMonkey 2.40a1 Mozilla/5.0 (Windows NT 6.1; 
   WOW64; rv:43.0 from official download area)  Gecko/20150813070342  
   Firefox/ 43.0  Build 20150817202009  (Classic Theme) on German WIN7 64bit
f) Same problem: "Bug 1202553 - Moving adresses between different adressbooks"
Whiteboard: as i said before, i used all the previous suggestions and this CTL one was used..it does NOT work.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202553
Whiteboard: as i said before, i used all the previous suggestions and this CTL one was used..it does NOT work.
Whiteboard: this is NOT resolved. This was CTL suggestion is useless and was mentioned for several years. I already tried it before sending in the bug report.....something in 2.35 and the 2.38b1 beta version has corrupted the code for drag and drop in address book. …
You need to log in before you can comment on or make changes to this bug.