Closed Bug 1203859 Opened 4 years ago Closed Last year

Implement a PlatformDecoderModule by using OpenMax

Categories

(Core :: Audio/Video: Playback, defect, P5)

ARM
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1306529

People

(Reporter: ayang, Unassigned)

References

(Depends on 3 open bugs)

Details

Current Gonk PlatformDecoderModule is based on Android MediaCodec which has following problems.
1. It can't support try tests in current ICS environment on try server.
2. It is not a standard interface. We need to modify it if any API is changed. For example, MediaCodec API is different between Andoird KK to L.

Goal:
Implement an OpenMax client to use OpenMax IL (IOMX on Android). This client implements PlatformDecoderModule and its own buffer manager.
Depends on: 1207969
It seems nice if we could avoid to sync wait dequeue buffer. Its timing could be notified like MediaCodecSource in L.
   https://github.com/sotaroikeda/android-diagrams/blob/master/media/MediaCodecSource_5.1.pdf
(In reply to Sotaro Ikeda [:sotaro] from comment #1)
> It seems nice if we could avoid to sync wait dequeue buffer. Its timing
> could be notified like MediaCodecSource in L.
>   
> https://github.com/sotaroikeda/android-diagrams/blob/master/media/
> MediaCodecSource_5.1.pdf

Yes, it's also one of goals, to get rid of stagefright.
Depends on: 1224887
Depends on: 1224889
Depends on: 1224890
Current plan:

1. add openmax il audio decoder.
2. add openmax il video decoder.
3. enable MSE test case on try emulator
4. replace GonkDecoderModule with openmax il PDM.
5. enable others media test cases on try emulator
6. remove all other Gonk decoder modules from gecko.
7. add GMP to openmax il PDM.
8. replace IOMX with real openmax il api on gonk (get rid of mediaserver)

Time line:
1, 2, 3, and 4 could be next release of Firefox OS (3.0?).
(In reply to Alfredo Yang (:alfredo) from comment #3)
> Current plan:
> 
> 1. add openmax il audio decoder.
> 2. add openmax il video decoder.
> 3. enable MSE test case on try emulator
> 4. replace GonkDecoderModule with openmax il PDM.
> 5. enable others media test cases on try emulator
> 6. remove all other Gonk decoder modules from gecko.
> 7. add GMP to openmax il PDM.
> 8. replace IOMX with real openmax il api on gonk (get rid of mediaserver)
> 
> Time line:
> 1, 2, 3, and 4 could be next release of Firefox OS (3.0?).
After 2.5, next version is 2.6 and its FC date could be in May. :)
Depends on: 1228183
I created bug 1228183 as to handle OMX_StatePause problem.
Depends on: 1229360
Depends on: 1229361
Depends on: 1229363
Depends on: 1231257
Depends on: 1231353
Depends on: 1231358
Depends on: 1231690
Depends on: 1231939
Depends on: 1233410
Depends on: 1238878
Depends on: 1240464
Depends on: 1241361
See Also: → 1306529
Assignee: ayang → nobody
Priority: -- → P5
Firefox OS is no longer relevant, but this would still be useful for desktop Firefox on RaspberryPi and other small arm-linux platforms like display signage.
OS: Gonk (Firefox OS) → Linux
This was implemented in bug 1306529
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1306529
You need to log in before you can comment on or make changes to this bug.