SyncEngine not retrieving latest records

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: mbdejong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8659784 [details]
irc log from #fxos-sync

irc log from #fxos-sync attached.
(Reporter)

Updated

4 years ago
Assignee: nobody → mbdejong
Blocks: 1200539
(Reporter)

Comment 2

4 years ago
I'll leave the ?_since= header commented out in https://github.com/michielbdejong/gaia/tree/1200539-sync-app-integration-tests until the 6-original-ids branch lands into Syncto master, then it should all work together.
Created attachment 8659970 [details]
Fixing JSON.parse error

Hi Michiel,

After applying Natim's patch at https://github.com/mozilla-services/syncto/pull/19, I still got JSON.parse error.

So I provide my patch for fixing the error in SyncEngine. Could you give me a feedback? Thank you!
Attachment #8659970 - Flags: feedback?(mbdejong)
(Reporter)

Comment 4

4 years ago
Comment on attachment 8659970 [details]
Fixing JSON.parse error

Hi Sean,

(In reply to Sean Lee [:seanlee] from comment #3)
> After applying Natim's patch at
> https://github.com/mozilla-services/syncto/pull/19, I still got JSON.parse
> error.
> 
> So I provide my patch for fixing the error in SyncEngine. Could you give me
> a feedback? Thank you!

RemoteTransformer.decode should never be called with data that does not need decoding. If that is happening then we need to fix that in kinto.js rather than working around it in this way.

I also saw JSON.parse errors yesterday morning, but last time I tested with the latest version of https://github.com/michielbdejong/gaia/tree/1200539-sync-app-integration-tests I did not see any JSON parse errors. Can you provide the steps to reproduce?
Attachment #8659970 - Flags: feedback?(mbdejong) → feedback-
(Reporter)

Comment 5

3 years ago
Closing this as UNCONFIRMED since I haven't seen it happen in the last two weeks.

Please reopen if we can reproduce it!
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Updated

3 years ago
Assignee: mbdejong → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.