[RFE] Please implement a way to recover bookmark folders inadvertently deleted

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: David A. Cobb, Unassigned)

Tracking

43 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150910030225

Steps to reproduce:

Trying to move a bookmark folder from one parent to another, my knuckle accidentally hit the right-mouse button.  Somehow, the result was to delete the folder I was dragging.  
Evidently, the deletion is immediate and irrecoverable.   Sad to say, it was a big collection. 


Actual results:

It's Gone, Gone, Gone!


Expected results:

It would be good to have if the deleted folder were moved to a "Trash" parent.  The trash could be emptied (comitted to Places) on exiting -- perhaps, as in TB, that could be an option.
(Reporter)

Updated

3 years ago
Severity: normal → enhancement
Component: Untriaged → Bookmarks & History
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
provided you didn't close Firefox yet, just open the Library (Show all bookmarks) and CTRL+Z (or choose undo from the Organize menu).

Alternatively, just restore the last backup containing the folder, from the Library / Import and backup / Restore
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1170541
(Reporter)

Comment 3

3 years ago
PLEASE REOPEN.

1. The method provided only works immediately; a "trash" folder would stay around.  
2. Recovering a backup goes too far back; maybe the snapshot could be taken when the session is opened, or even every NN minutes.  

IN THE ALTERNATIVE
I can open a new RFE requesting the "Undo" function be made available on the main window Edit menu.
We are not considering adding a trashcan or similar functionality at this time, sorry. The backups are taken every day, if any bookmark changed.

Unfortunately any bug would end up being marked at wontfix, cause we already have methods to recover bookmarks that would satisfy most users and we have no resources at all to implement further. Or alternatively it may stay open forever, that is not any better.

If anything would ever happen, it would be after we revise the complete bookmarks experience to improve it, cause that would always have an higher priority.
You need to log in before you can comment on or make changes to this bug.