Disable Async Plugin Init for FF41 Release

VERIFIED FIXED in Firefox 41

Status

()

Core
Plug-ins
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ritu, Assigned: aklotz)

Tracking

41 Branch
mozilla41
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox41+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Based on QE recommendation and known issues in this area, we should pref "dom.ipc.plugins.asyncInit.enabled" to false by default in FF41.
(Reporter)

Comment 1

2 years ago
Aaron, would you be able to create a patch and nominate for uplift before we gtb 41 RC on Monday? Thanks!
Flags: needinfo?(aklotz)
(Reporter)

Comment 2

2 years ago
[Tracking Requested - why for this release]: Async plugin init still has issues and may not be release ready. Let's disable for 41.
status-firefox41: --- → affected
tracking-firefox41: --- → ?
(Reporter)

Comment 3

2 years ago
Tracked so we keep an eye on this one until it lands and any possible regressions.
tracking-firefox41: ? → +
(Reporter)

Comment 4

2 years ago
Vladan, also n-i'ing for your help here to get the patch landed asap as I gtb 41 RC in an hour or so.
Flags: needinfo?(vladan.bugzilla)
Created attachment 8660813 [details] [diff] [review]
Disabling

Approval Request Comment
[Feature/regressing bug #]: async plugin init
[User impact if declined]:
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: 
[String/UUID change made/needed]: none
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Flags: needinfo?(vladan.bugzilla)
Flags: needinfo?(aklotz)
Attachment #8660813 - Flags: approval-mozilla-beta?
Comment on attachment 8660813 [details] [diff] [review]
Disabling

Self reviewing since it's just a pref toggle.
Attachment #8660813 - Flags: review+
(Reporter)

Comment 7

2 years ago
Comment on attachment 8660813 [details] [diff] [review]
Disabling

[Triage Comment] Thanks Aaron for providing a patch promptly. Approving for uplift to moz-release so this is included in 41 RC build.
Attachment #8660813 - Flags: approval-mozilla-beta? → approval-mozilla-release+

Comment 8

2 years ago
I don't understand this request. It it disabled for all plugins except a short whitelist anyhow already from what I understand. Do we still have issues with the whitelisted plugins as well? If so, can you point me to the respective bugs?
https://hg.mozilla.org/releases/mozilla-release/rev/4d6a54f1317f
status-firefox41: affected → fixed
Also landing to beta at Ritu's request: https://hg.mozilla.org/releases/mozilla-beta/rev/5e9b2a323145
Flags: qe-verify+
See Also: → bug 1116806
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This was covered by Plug-in compatibility testing performed in Firefox 41 RC build 1 (https://docs.google.com/spreadsheets/d/1rQS6fGgzlWHfk3zDbe-6gK5ESirvPCI6YcESlpg2Sk0/edit#gid=1224410939). No new issues were encountered, so marking this as verified.
Status: RESOLVED → VERIFIED
status-firefox41: fixed → verified
You need to log in before you can comment on or make changes to this bug.