Closed Bug 1204092 Opened 5 years ago Closed 5 years ago

Autophone - 2015-09-11 deployment

Categories

(Testing :: Autophone, defect)

defect
Not set

Tracking

(firefox43 affected)

RESOLVED FIXED
Tracking Status
firefox43 --- affected

People

(Reporter: bc, Assigned: bc)

References

Details

Attachments

(1 file)

Perform a deployment to pick up bug 1203535 which changes the unit tests to use adb instead of sut.

As a part of the deployment, I will remove the sutagent from the devices and partition the unit tests better now that we are not constrained to run them on devices with a working sut with su.

As gbrown mentioned in bug 1203535, testAdobeFlash will not be run on the nexus s Android 2.3 devices.
r=bc. This patch adds try to all tests/devices. This will allow us to test every test against every device in order to discover any device specific issues before putting a device/test combo into production.
Attachment #8660198 - Flags: review+
Fri Sep 11 16:22:25 PDT 2015: devices shutdown, local repo updated, sutagent uninstalled, host rebooted.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
FYI, this deployment using adb instead of sut for the unit test transport has resolved the issues with rca. However, while testing all of the devices and tests using the new try manifests, I found that I can reproduce the issues with the other unit tests failing due to exceptions. I am investigating the possibility the issues are due to multiple simultaneous adb accesses from different processes to a device causing adb to crash.
You need to log in before you can comment on or make changes to this bug.