Page able to open pop up windows even though they are disabled

RESOLVED DUPLICATE of bug 126224

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 126224
16 years ago
16 years ago

People

(Reporter: Jacek Furmankiewicz, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Trunk
mozilla1.1alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    0.9.7

I went to this CDNOW.com page and it opened a popup...even though I have "open
windows by themselves" switched OFF (and it works on other sites).
Obviously they must have found a way around that.

Reproducible: Always
Steps to Reproduce:
1. Disable pop ups (Preferences->Advanced->Switch OFF "open windows by themselves"
2.Go to the URL: 
http://cdnow.com/cgi-bin/mserver/SID=609001184/pagename=/RP/CDN/FIND/album.html/artistid=GALAS*DIAMANDA/itemid=170313

3.

Actual Results:  Pop up appears "Welcome to CDNOW, sign in to your account...etc"

Expected Results:  There should be no pop up

Comment 1

16 years ago
Reassigning to DOM and to mstoltz; cc'ing jst, rginda
This may be what's doing it: 

<script language="JavaScript">

function openWelcome ()
{
  welcomewindow = open('http://cdnow.com/cgi-bin/mserver/SID=1104006024/
                        pagename=/RP/CDN/welcome.html', 'Welcome',                                                                               
                        'width=200,height=297,toolbar=no,location=no,
                        directories=no,status=no,menubar=no,scrollbars=no,
                        resizable=no,fullscreen=no');

  if (welcomewindow.opener == null)
    welcomewindow.opener = self;
}

</script>

<img src="http://gs.cdnow.com/graphics/spacer.gif" width=1 height=1                
onLoad="openWelcome(); return true;">
Assignee: rogerl → mstoltz
Status: UNCONFIRMED → NEW
Component: Javascript Engine → DOM Level 0
Ever confirmed: true

Comment 2

16 years ago
Setting default QA -
QA Contact: pschwartau → desale
(Assignee)

Comment 3

16 years ago
Aargh, they've caught on. We don't currently block opens in the onLoad handlers
of images. We might be able to do that, although this is ultimately a losing
battle - eventually they'll pop up windows on mouseMove or mouseDown events, and
then we'll really be screwed.
Status: NEW → ASSIGNED
QA Contact: desale → pschwartau
Target Milestone: --- → mozilla1.1
(Reporter)

Comment 4

16 years ago
Wouldn't it be simpler to keep track of whether a window is being opened via a
user clicking explicity on a page (so basically just process A HREF tags and
onClick()) and just disregarding everything else if this option is switched OFF?

Or is that too complex too implement in the current JS engine?
(Assignee)

Comment 5

16 years ago
No, that's where we're headed, more or less, although it will be a lot of work.
And the more restrictive we are, the more likely we are to block non-ad windows.
(Assignee)

Comment 6

16 years ago
*** Bug 126905 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Setting default QA -
QA Contact: pschwartau → desale

Comment 8

16 years ago
I think there would be ultimate solution in just allowing any popups from the
page's javascript only in some short time after user's click anywhere in the page.
It can be used for advertising too but the ad window would never appear without
explicit action of the user.
OS: Windows NT → All
Hardware: PC → All
*** Bug 127757 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Isn't this one the same that bug 126224 ? (fixed on trunk)

Comment 11

16 years ago
I'll make it a duplicate because this new solution is exactly the same as I
suggested in comment #8. And there is no way the first solution will work for
every trick the web developers could think of.

The new solution however needs UI work (it is only a text pref).


*** This bug has been marked as a duplicate of 126224 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.